Input Table: the field is not rendering the filled inputs correctly in the PDF editor and notifiers

  • Profile Image
    wslaman6
    Asked on September 04, 2019 at 09:13 AM

    Hi there!

    I am currently doing some tests with the free version of Jotform to see if it could help with our business.

    I made a form containing different kinds of questions.

    Among them I included a lot of checklists using bulletpoints  (tick yes, no, don't know) and added a small text box at the end of each row for comments.

    I was able to fill out the form and submit it. I do receive the submission but all the ticked bulletpoints and text does not display in the submission (or the pdf)

    Basically The answers that people give to my questions are not being saved/displayed so I do not know what they answered.

    In the url below you find my checklist. I hope there is a simple fix to this.

    Thanks in advance!

  • Profile Image
    Welvin
    Answered on September 04, 2019 at 09:39 AM

    Your screenshot seems to be from the PDF document. Is this through the PDF Attachment in the form email settings? You have this option disabled, so please clarify.

    I checked this through your form and my cloned version of the form, and I cannot seem to replicate the problem. In the PDF, you can see the options are there:

    Note that it is recommended to open the PDF Document using Adobe Acrobat or any other PDF reader tool. 

  • Profile Image
    wslaman6
    Answered on September 04, 2019 at 10:43 AM
    Hi, thank you for your respomse.
    The screenshot is from the pdf that I generated from a submission that I
    received and opened with acrobat pdf reader.
    As you can see all of the check boxes are ticked/selected in the pdf but
    the person filling in the form has only selected one of the three
    Furthermore, all boxes that somebody has entered text into during the
    filling of the form, it only displays a letter (t) instead of the answer
    that they wrote.
    ...
  • Profile Image
    Welvin
    Answered on September 04, 2019 at 11:34 AM

    Thank you for the additional information. I can see it now, and tried your form and found a few issues.

    a. The PDF editor is checking all options despite checking just a few before submitting the form.

    b. The PDF editor is not saving Texts input in the Textbox column.

    c. The data is not saved when you try to edit the submission.

    Let me investigate this further and get back to you on this. So far, I cannot replicate this problem on a new form. 

  • Profile Image
    Welvin
    Answered on September 04, 2019 at 01:21 PM

    I'm sorry, but I cannot seem to find the culprit of this problem. I still cannot replicate this even when copying your options, including that extra break (br) tags. I tried removing the progress bar and page break, still the same.

    I have escalated this thread to our backend team for additional help. Once we have an update, you'll be notified here. 

  • Profile Image
    wslaman6
    Answered on September 05, 2019 at 02:43 AM
    Thank you very much for your fast work!
    If you manage to find the problem with the bullet points I would be happy
    to hear it.
    For now I have made it work by making a clone of my form and changing all
    bullit points to check boxes. Now it seems to work fine and also the text
    is saved now.
    Have a nice day!
    ...
  • Profile Image
    AndrewHag
    Answered on September 05, 2019 at 03:58 AM

    I am able to replicate the issue on your form. I believe the issue is because you are using Multi Type column for the input table field. It should work fine if you change the type of column to any other.

    However, this issue has already been escalated to our backend team. You will be notified if there is any update.