What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    If a condition is set to to show a field when list option is selected, then why is the field showing before the selection is made?

    Asked by cheekyface on April 27, 2013 at 04:32 AM

    If a condition is set to "show" a field when a list item is selected then by default should that field to be shown, remain hidden until that item is selected?


    In my example I have a list of only 3 states to choose from and then the fourth option = "other"
    When "other" is selected it should display another field with all the other states not included in the first list.

    I have set the conditions to:

    If "State" Field equals to "Other"
    Show the field "pick from this list"

    So should it not hide the field "pick from this list" until the "State" field option "other" has been selected?

    At the moment when I come to the question "State?" the field below it ("pick from this list") is showing but if I select then de-select the "Other" option in the State field then it will hide.

    I've saved a clone of the from for you to check so that I can keep woking on this.
    I guess I can always do it another way and make the condition to Hide "pick from this list" if not equal to "Other" but i wanted to check this anyhow as i recall it worked that way once before.

    Page URL:
    http://jotform.co/form/31161590194855

    Screenshot
    hidden selected check saved show field hide field condition
  • Profile Image
    JotForm Support

    Answered by Welvin on April 27, 2013 at 06:09 AM

    Hi,

    Yes, the field that is set to the condition to "show" after a certain option from another field is selected will remain "hidden" until the option is selected.

    I guess it's working fine;

    When no option is selected from state:

    When Other is selected from State:

    Clear your browsers cache and if you can't see this changes.

     

    Thanks

  • Profile Image

    Answered by cheekyface on April 27, 2013 at 07:42 AM

     

    Please try this one.  
    http://jotform.co/form/30788413011851 (original form)

    This is the original (and the clone is the one I included in the original post).  For some reason it seems the clone works but no matter how many times I clear the cache and cookies I still don't get it working properly on the original.  
    I will just use the clone and delete the original as I haven't made any changes but it may help if you can see anything in the original that I can't. 

    Maybe I have a browser issue ...I'm using chrome but just tried it with firefox and same thing.  I don't know what is the difference now between the two.  

     

    By the way how do you add a screen shot to a post?  I can only add images that have a URL.

  • Profile Image

    Answered by jefreylandicho on April 27, 2013 at 01:45 PM

    I have tested both of the forms you have provided and they work exactly the same. I have manually clear your form cache on our end. Please try deleting your browser offline files and check your form again. 

    Regarding your second question, we use Image URL to add screenshot in our post as well.

  • Profile Image

    Answered by cheekyface on May 05, 2013 at 10:15 PM

    Thanks for this.  To make it simple I'm going to just delete the original as, even after clearing the cache and even using browsers I rarely use (firefox & explorer) it still doesn't behave as per the conditions set.  Not sure why but I'm just hoping it won't repeat itself in the duplicate form which seems to be working fine.

     

    Thanks for your help.

     

    BTW, Where do I find the browser files on Windows 7?

    Fro chrome I've gone to C:\Users\PC\AppData\Local\Google\Chrome\User Data\Default\Cache  ...does this look correct?  I'm reluctant to delete anything as I'm worried I'll delete the wrong thing.

  • Profile Image

    Answered by cheekyface on May 06, 2013 at 12:28 AM

    ...It's doing it again.

    http://jotform.co/form/31161590194855

    This time it's the question "do you have a P/O number?" that is the trigger.  When the option selected is yes an additional field is to display below it to allow you to input this P/O number.  However this field is already visible when I come to this page ...I think it's page 6.

    The field is:  Add your Purchase Order number here:

    There is an additional condition for this field which is to hide it (along with a bunch of other fields) if the first question is selected as "quick quote".  

    If the first question is not selected as "quick quote" then would that affect the second condition which is to only show "add your purchase order number here" only when "do you have a P/O number?" = YES.

    Is there a better way to set up the conditions in this case?

    ------------------------------------------------------------------

    I actually just tried setting the default selection for the field "do you have a P/O number?" to = "No" and hoping that would hide the following field.  It didn't though.  Instead I had to select "Yes" first and then "No" again for it to hide.  I did this in a cloned version of the above form so I'm thinking there's no way for the cache to be an issue in that case.  Could it be?

    It seems there is something wierd going on and I've read from another topic that one person was having a similar issue but the issue fixed itself after about 20 minutes or so.  Also a bewildered user who could not explain why that was happening. 

  • Profile Image

    Answered by cheekyface on May 06, 2013 at 05:21 AM

    I think I've worked out the problem - the duplicate condition on the same field was the problem so I've removed one.  

  • Profile Image
    JotForm Support

    Answered by Welvin on May 06, 2013 at 09:05 AM

    Hi,

    Good day! I didn't checked your form again but I'm glad that you have sorted that out. That is indeed the reason why, duplicate conditions on the same field will caused the conditional logic for the particular field not to work.

    Should you have any further questions or problems, please don't hesitate to contact us again.

    Thanks

  • Profile Image

    Answered by Luiz  on November 27, 2014 at 02:53 PM

    Hello, 

    I have the same problem if my form. 

    But not only the if does not work the way I want it does the exact oposite. When Yes it hides the next step instead of showing it.

    http://form.jotformpro.com/form/43294980520962 

    Its the third question (Você fez uma ou mais viagens à Franç...)