What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Issue with Zoho integration

    Asked by cheekyface on May 10, 2013 at 11:44 AM

    Hi.

    I've just recently created a basic booking form and set up an integration with Zoho CRM leads.

    When I test the form it works and sends the subitted data to the CRM but since my first test there have been 2 customer submissions and they did not submit to the CRM.  All I received was the email notification which is the only reason I know they are there.  I then tested it again and the test submitted the data to the CRM.

    Not sure why this could be happening.  Hope you can help.

    The form is at: http://jotform.co/form/31254281294856

    Page URL:
    http://jotform.co/form/31254281294856

    zoho Submissions JotForm booking form email email notification
  • Profile Image

    Answered by pinoytech on May 10, 2013 at 01:33 PM

    Hi,

    We apologize for the inconvenience that may have caused. With regards to the issue, have you tried already re-integrating your form to Zoho? If not, can you please give a try? And see if the said issue still persist or not.

    Thank you!

  • Profile Image

    Answered by cheekyface on May 10, 2013 at 07:20 PM

    I wont have a chance to do that for a day maybe.  Could you please try completing & submitting the form as a test.  Please try with a mobile device as well as a desktop if you could.  I'm wondering if that might not be what is affecting it.  
    I've tried it with both and it works fine.  I can't explain why those two real submissions didn't convert to a lead though. 

    I cna reset the integration just in case but will probably wait to see how it goes with another customer booking.

  • Profile Image
    JotForm Support

    Answered by jonathan on May 10, 2013 at 10:42 PM

    Hi, 

    I have test submitted this form http://jotform.co/form/31254281294856 using iphone device emulator.

     

    Please check on your Zoho account if my test submission was recorded. I could see the submissions properly recorded on the form's submissions page.

     

    Please update us. 

    Thanks.

  • Profile Image

    Answered by cheekyface on May 11, 2013 at 04:19 AM

    Thanks Jonathan.

    It worked.  
    I can't think why it failed on those two occasions.

    I had a look at my iphone some time after testing the form myself and there was an error message that has replaced my "thank you" message:

    "ERROR
    Form ID did not match.  Form ID: Form Name: 31254281294856" 

    Might this have anything to do with it?

  • Profile Image
    JotForm Support

    Answered by jonathan on May 11, 2013 at 09:37 AM

    I am sorry, I could not reproduce this error message.

    I just tested again on the Iphone emulator. and on Desktop. But the Thank you meassage alwasy displays properly.

    Are you able to repeatedly reproduce this error message on your Iphone device?

    Thanks.

     

  • Profile Image

    Answered by cheekyface on May 11, 2013 at 07:05 PM

    Submissions:
    Jonathan, looking at the submissions in jotform it shows 3 entires with your name.  I only received one in Zoho.
    Is that possibly to do with the de-duplication settings? 

    Error:
    I also get the same thank you message and I also did the time I got that error message. I only saw the error message about an hour after I submitted the form when I happened to look at my phone. It must have displayed at Lear a few minutes after the thank you but it had a jotform logo on it so it wasn't an iPhone error message. It looks like it working now anyhow. Ill leave it for now and will get back to here if the problem should repeat.Thanks for your help.

  • Profile Image

    Answered by cheekyface on May 11, 2013 at 07:50 PM

    I just tried to re-submit some of the entries that were in the submissions area on jotform and those same two original entires will not create a lead.  The others seem to work still.

    Both the entries that aren't working were made on 2013-05-09 

     


  • Profile Image
    JotForm Support

    Answered by liyam on May 11, 2013 at 10:40 PM

    Hello cheekyface,

    To answer your 1st concern: Yes, zoho has a dedup method which only allows one entry for each similar submission.  So it disregards the other duplicates.

    Can you identify if those that did not forward to your Zoho integration had already previously sent a submission using the same email address?

    Also, can you provide us more details on your Zoho so for us to identify better the possible issues what's causing this?

    Thanks.

  • Profile Image

    Answered by cheekyface on May 28, 2013 at 11:14 PM

    Hi guys.
    Sorry for the delay with this but I've been busy with other stuff.  I hope you can still help me figure this out.

    It does appear that the deduplication is playing a part in this but at the same time it seems to be selective.
    I have a clear leads list and with no other leads it still will not accept the submission, yet on the other hand if i submit a form with my name as many times as I like it will submit and receive in zoho leads (updates existing currently but at least I get the submission).  

    I'm giving up on this and will eventually just divert via zapier as they have an integration option between jotform & zoho and I think it works fine.  Would be better if we didn't have to rely on a third party to get this to work.

    latest attept to use the booking form:
    I submitted details for a customer and the form submission is recorded in jotform but not in zoho leads.
    the customer alrteady exists in our contacts but the lead is where new form submissions for a quote are received or booking form submissions (as is this case).  
    I tried to remove the integration and re-set it.  I also later tried to change the way the integration works by setting it to update existing details.  That made no difference to the leads list either.

    If you guys can figure out what the problem is please let me know but if it has to do with zoho then I'm leaving it as I've been over similar issues with them enough times and they don't seem to care how the deduplication affects me.

     
    Thanks for your help on this anyhow. 

  • Profile Image
    JotForm Support

    Answered by Welvin on May 29, 2013 at 02:49 AM

    Hi,

    I have cloned your form and made the integration and everything was successfully transmitted on Zoho CRM.

    The integration: 

    The Zoho Data:

    \

    It is probably your current Zoho Field Settings. Especially the Data Type. Here's my settings:

    Quote Number = Text in Zoho

    Comments = Text Area in Zoho

    Agreement = Checkbox in Zoho

    Company = Text In Zoho

    Please kindly check and make sure you have the same.

    ------

    Please try to submit a data to my cloned form, let us see if it will forward to Zoho CRM. http://form.jotformpro.com/form/31480935758969?

     

    Thank you!