Checklist widget: Unable to submit the form when validation on the Checklist widget is turned on

  • Profile Image
    kut123
    Asked on March 20, 2020 at 12:27 AM

    Hi, I keep getting incomplete responses on my forms from some users even though on their side they have completed all the required fields.

    I have included 2 screen shots. A completed one and an uncompleted response

    I have included the link to the form

    How can I fix this?

  • Profile Image
    ferhat
    Answered on March 20, 2020 at 12:52 AM

    Hi, 

    You can set the form field Required in order not to get incomplete responses:

    1. Click the Properties button.

    2. Under the General tab.

    3. Change the Required field from No to Yes.

    1584679877Screen Shot 2020-03-20 at 07.4

    Please let us know, if you need more help.

  • Profile Image
    kut123
    Answered on March 20, 2020 at 01:16 AM

    1584681396New form.jpg

  • Profile Image
    roneet
    Answered on March 20, 2020 at 01:57 AM

    I was able to replicate the issue in your form. Since you already have 28 submissions so may we know since when you started experiencing this issue in your Checklist widget? or you have never enabled the mandatory validation in your form?

    Since this Checklist widget is not working when the mandatory validation is enabled, you can use the traditional Checkbox with validation and disable the existing widgets with the mandatory validation turned off.

    Please do not delete the Checklist widget as it will also permanently delete the existing submissions.

    You can take a backup of the existing submissions:

    Check these guides:

    https://www.jotform.com/help/374-How-to-Export-All-of-Your-Data-at-Once

    https://www.jotform.com/help/73-How-to-Download-Form-Submissions-as-Excel-CSV-PDF

    https://www.jotform.com/help/356-How-to-Download-the-Submission-Files

    Let me open a bug ticket for the Checklist widget. We will get back to you once we have an update.

    Thanks.

  • Profile Image
    hayk
    Answered on March 23, 2020 at 06:02 AM

    We are sorry for the inconvenience caused to you. We have updated the widget and the problem has been resolved. Please clear your browser's cache and check out the widget once again. Let us know if the issue persists. Thank you for reporting the issue.

    Regards,

    Widgets Team

  • Profile Image
    kut123
    Answered on March 23, 2020 at 06:07 AM

    Thank you, I'll test and provide feedback