What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Empty My Forms page when using IE10 in Windows 8 (Desktop Version)

    Asked by gandhik on June 01, 2013 at 07:19 AM
    Page URL:
    http://bcpcicpag.co.uk/#/blank-page/4563940021

    Screenshot
    My Forms forms not there can't find forms
  • Profile Image

    Answered by sidharth_kch on June 01, 2013 at 11:02 AM

    @gandhik

    I checked your account and don't see any issue with that. All the forms are there in your account. Request you to please clear your browser cache and log back in to your JotForm account.

    Let us know if you continue to have this issue and we will investigate further.

    Thanks,

    Sidharth

  • Profile Image

    Answered by gandhik on June 01, 2013 at 12:13 PM

    cleared everything, still does not work.

  • Profile Image
    JotForm Support

    Answered by abajan on June 01, 2013 at 02:14 PM

    @gandhik

    Like my colleague, I was unable to replicate the issue. Are you on the My Forms view of your account? The link should be grey.

  • Profile Image

    Answered by gandhik on June 02, 2013 at 04:42 AM

    cracked it - my default browser is internet explorer 10, which shows blank list of MY FORMS.

    Used Google Chrome to login to Jotform and MY FORMS are all showing now.

    If I change my default browser to google chrome then I loose the win8 internet explorer app from the start window tiles.

    It seems I will have to login via google chrome fro m now on, unless there is a fix using IE10.

     

    Further finding, the problem is with the desktop version of IE10 / Win8 and not with the Win8 App  IE10 from the start metro.

     

    Any suggestion in using the desktop version IE10 please?.  

  • Profile Image
    JotForm Support

    Answered by Welvin on June 02, 2013 at 05:23 AM

    Hi,

    Let me forward this thread to our developers for further investigations. You should received an email alerts via this thread for updates.

    While waiting, suggest you to use Google Chrome.

     

    Thanks for reporting.

  • Profile Image

    Answered by cettox on June 04, 2013 at 09:52 AM

    @gandhik

     

    I was unable to replicate the issue, using both desktop versions and metro versions.

     

    Can you check now to see that problem is gone or not? Or give us more details on how to reproduce the issue.

     

    Thanks.

  • Profile Image

    Answered by gandhik on June 04, 2013 at 01:44 PM
    The problem is still there
    Please see attached file


    Regards
    Kishor

  • Profile Image

    Answered by pinoytech on June 04, 2013 at 02:43 PM

    @gandhik,

    Upon checking your account, I only found one form "Update Clinical Record". However, when I check your Trash, I see that most of your forms are there specially "Change of Contact Details" form the one embedded into your website. In order to restore this form, just simply go to your Trash > then click the form you want to be restored > then click Restore Form.

    If you need further assistance, do let us know.

    Thank you!

  • Profile Image

    Answered by gandhik on June 04, 2013 at 05:22 PM
    You totally misunderstanding the problem.

    I don’t want to restore any forms.
    I am aware I have lots of forms in the trash, because I put them there.

    I have and meant to have only one form in MYFORM i.e. “Update Clinical Record”.

    I am trying explain the problem as when you use desktop version of IE10 JOTFORM will show an empty list, means this one and only form does not show plus all the buttons are disabled.

    When you use IE10 the metro version the list will show my form “Update clinical Record”
    When you use google chrome the list will show my form “update clinical record”

    Please don’t look for any forms, I know my account should only have one form, the “Update clinical record” form.

    Please follow previously sent screen capture and you will understand that there is a problem with JOTFORM under desktop version of IE10/Win8 only.


    Regards
    Kishor Gandhi

  • Profile Image
    JotForm Support

    Answered by Welvin on June 04, 2013 at 09:37 PM

    Hi Kishor,

    We'll try to replicate this on our end so please stay tune, this thread is still currently assigned to one of our developers.

    Please consider using Metro Version and or Google Chrome while waiting for an update.

    Thanks for your patience and understanding.

  • Profile Image

    Answered by mmaddux on August 27, 2013 at 02:25 AM

    It seems to be some sort of compatibility issue with IE10. I noticed that if you change your browser setting to the compaitblity view, the form will appear. Any thoughts on how to make it show from the get go? A lot of people appear to be having this script issue with IE10.

  • Profile Image
    JotForm Support

    Answered by EltonCris on August 27, 2013 at 05:53 AM

    @mmaddux

    Just like the developer has said, I am unable to replicate the problem. Tried it with compatibility mode on and off. It works just fine.

    Can you please open a new thread and give us further details or a step by step instruction on how to reproduce the problem? Your help would be greatly apprecaited so we can track the issue out.

    Thank you!

  • Profile Image
    JotForm Support

    Answered by steve on August 26, 2014 at 01:53 AM

    Hello,

    This issue has been fixed for a while.

    "Empty My Forms page when using Internet Explorer 10 in Windows 8."

    Please let us know if you encounter further issues.

    Kind Regards

  • Profile Image

    Answered by gandhik on August 28, 2014 at 10:29 AM

    System upgraded to windows 8.1 and IE11 therefore the problem has gone for me.

    please close thread.

    thank you

    gandhik