Conditions don't work on an embedded form

  • Profile Image
    frankowen
    Asked on May 31, 2010 at 08:13 AM
    Hi Aytekin

    I have a form (http://www.jotform.com/form/1261111177) with conditions (regarding payment types) which work fine as a standalone form but, as soon as I embed it into our own website, the form looks correct but the conditions don't work. Also, the 'Other' field in a radio button (dietary choices) won't activate and provides a spurious 'on' as answer to the question.

    Everything else seems to work OK. I can submit and the auto-responders work but I'm rather keen on having the payment types appear only with the correct selection. Otherwise, people might select both but only pay with one.

    Frank
  • Profile Image
    aytekin
    Answered on June 01, 2010 at 03:24 PM
    We will look into this problem. For now, can you replace the code on your site with short form source code you see on the "Share Form" wizard.
  • Profile Image
    frankowen
    Answered on June 03, 2010 at 08:19 AM
    Hi Aytekin

    That was what I had used. I have now embedded the full source code and it works.

    I have experienced inconsistency before with Conditions, where they don't work and yet, when I return some time (perhaps a day) later, they are for some reason working without any changes on my part.

    Anyway, the problem's gone away (in my form at least).

    Thanks

    Frank
  • Profile Image
    aytekin
    Answered on June 07, 2010 at 07:13 AM
    I am glad it is resolved now. Thanks for the update.