What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    trouble with conditional autoresponders

    Asked by lomitadogtraining on June 18, 2013 at 12:56 AM

    Hi there. My form has a number of conditions, based on how many of the three team members ask for lunch (as this changes the amount of money we ask them to bring in the auto-responder email). For the three members, there are 8 possible combinations of "no"s/"yes"s for lunch. Thus I have:

    8 conditions that affect which form field displays at the bottom of the form (which displays the total dollar amount) -- these 8 conditions work perfectly.

    8 conditions that dictate which version of the auto-responder go out. These are based on the same 8 rules as the above, but the emails aren't going out.

    I've had the following thoughts but ruled them out: Is the problem due to the fact that I'm trying to send out the same autoresponder to more than one email address via a single condition? No: I tried only sending one email in a condition, and it still didn't send. Are the conditons for displaying form field somehow conflicting with the conditions for sending the emails? No, when I deleted one of the display form field conditions, the corresponding autoresponder still didn't send.

    I'm not yet using the form on a site, I'm just previewing at http://form.jotform.us/form/31667530143147?

    Any thoughts?

    Thank you much,

    Michael

    (Note: I know that JotForm could integrate PayPal and act as a shopping cart. No, I don't want to do that. Thank you though.)

    autoresponders Emails display form JotForm email problem
  • Profile Image

    Answered by dinesh-it on June 18, 2013 at 01:40 AM

    Hi, First off all Thanks a lot for this brief description about your issue. It will really help us lot.

    I Cloned your form and did a test submission and I am able to receive both notification and autoresponder.

    Please check again and dont forget to check your spam folder.

    If still you have this issue, please let us know how you are reproducing this issue. Like at what condition you are not getting autoresponder mail.

    Thank you.

  • Profile Image

    Answered by lomitadogtraining on June 20, 2013 at 01:22 AM

    Still having trouble, but I've done a lot more testing and I've narrowed it down a bit. It seems that with each auto-responder condition (each of which has three actions, to send an email to three different email addresses), only the action that happens to be listed last in the condition is actually sent. The result is that one of the three emails is sent. I've done all my testing with the $75 and $90 conditions, so if you try to duplicate, I suggest you use either of those. But I suspect it's the same for all. But by simply changing the ordering of the actions listed in the condition, I was able to change which of the three emails got sent. Is there something I can do about this? Is the only solution to set up a separate condition for each email address (24 mail conditions instead of 8)? Thanks.

  • Profile Image

    Answered by dinesh-it on June 20, 2013 at 01:59 AM

    Hi, Sorry for the inconvenience. I checked your condition and found that you have 3 actions for same notification with different mail ID's. Instead of doing like that, We can add different email's to same Notification by comma seperated values.

    Like {email1}, {email2}. {email3} .. etc. (upto 10 mail ID's per notification)

    So I suggest you to try Condition as shown below:

     

    Try this and let us know the result.

    Thank you.

  • Profile Image

    Answered by dinesh-it on June 20, 2013 at 02:11 AM

    Well, I Did a test submission on my cloned form with 3 different mail Id's with the above condition. IT is working fine now.

    Thank you.

  • Profile Image

    Answered by lomitadogtraining on June 20, 2013 at 10:16 PM

    That seems to do the trick -- thanks for the hands-on support!