Conditional Logic: Fields not hidden

  • Profile Image
    mcmanuslawyers
    Asked on June 04, 2020 at 04:59 AM

    Hi Jotform. I am having issues with conditional logic. I have set an answer to show further questions when answered in a certain way, but the questions will not hide when answered in another way. Even though i have set it to hide! Can you please help? Thank you.



    This is a re-post of a comment on Smart Forms: Conditional Logic for Online Forms

  • Profile Image
    Jovanne_A
    Answered on June 04, 2020 at 07:40 AM

    Hi, thank you for reaching out to us.

    Could you please provide the link of the form you are currently working with so we could further investigate the issue?

    We look forward to your response.

  • Profile Image
    mcmanuslawyers
    Answered on June 04, 2020 at 07:05 PM
  • Profile Image
    Jovanne_A
    Answered on June 04, 2020 at 07:12 PM

    Hi, thanks for your response. Could you please give us more details about the questions that will not hide when answered? Or provide us a screenshot so we could further investigate.

    Guide:
    How to Post Screenshots to Our Support Forum

    We look forward to your response.

  • Profile Image
    mcmanuslawyers
    Answered on June 04, 2020 at 07:18 PM

    Hi, this is the main question i have issues with. 

     I have set an answer to show further questions when answered Joint owner or co-owner, but the questions will not hide when answered single owner. Even though I have set it to hide! Can you please help? Thank you.

    1591312669Screenshot.jpg

  • Profile Image
    Jovanne_A
    Answered on June 04, 2020 at 07:33 PM

    Thank you for your response.

    As per checked on your form, the conditions are working fine in my end (see attached photo).

    159131346921.gif

    I suggest that you would clear your browser cache and check your form again.

    Guide:
    How to clear your browser cache


    Let us know if you need further assistance.

  • Profile Image
    mcmanuslawyers
    Answered on June 04, 2020 at 07:40 PM

    Hi, thank you for checking the issue. I cleared my cache and it is still showing the co-ownership questions when single owner is checked. Any other suggestions?

  • Profile Image
    Jovanne_A
    Answered on June 04, 2020 at 07:52 PM

    Hi, could you please try to select the single ownership by default?

    159131470822.png


    Let us know if the problem still persists.

  • Profile Image
    mcmanuslawyers
    Answered on June 04, 2020 at 08:04 PM

    Hi Jovanne, thanks for your help. That works.. However, if i choose joint and try to go back to single, the co-ownership questions stay. Not sure if that can be fixed?

  • Profile Image
    Jovanne_A
    Answered on June 04, 2020 at 08:14 PM

    Hi, thank you for your response.

    I couldn't see any errors in your conditions. Have you tried checking your form to other browsers?

  • Profile Image
    mcmanuslawyers
    Answered on June 04, 2020 at 08:37 PM

    Hi, unfortunately it is still happening. If the conditions like correct then it might be a glitch.

  • Profile Image
    Kevin_G
    Answered on June 05, 2020 at 12:14 AM

    I have checked the form you originally shared https://form.jotform.com/201278068492864 and it seems like this changed a bit as I could not find the questions showing up on the screenshot shared on this ticket. 

    Now, checking your forms I found this one that has the same questions: https://www.jotform.co/form/91552049558868 

    I see the following issue:

    15913303851.gif

    The issue is that conditionally hidden fields remain filled, you can set up your form to clear these hidden fields, you will find the option on your form settings:

    15913304772020-06-04_22h14_20.png

    I hope this helps.