Email Validator widget and Random Value Generator Widget failing to load

  • Profile Image
    farsheed
    Asked on June 11, 2020 at 03:23 AM

    Hello

    Once again a recurring problem...

    All forms have the same problem as this one below

    1591860091jotformwid1.gif

    The 2 widgets fail to load, this has been happening since yesterday off and on.

    Sometimes renders and sometimes breaks like shown above   

    What do you you advise ?

  • Profile Image
    ashwin_d
    Answered on June 11, 2020 at 07:12 AM

    I am sorry for the trouble caused to you. I did check your form and tried to replicate the issue you are having. Email validator widget seems to work as expected. Please check the screenshot below:

    1591873528emailValidator.gif

    I refreshed your form multiple times and email validator widget was displayed successfully. Is this issue happening in any specific browser? Have you embedded your form in any web page where you are having this issue? Please share the web page URL, and we will take a look.

    On your question related to "Random Value Generator", it is not being displayed in form because you have enabled "Run in the Background" setting of this widget. Please check the screenshot below:

     1591873801randomValue.gif

    I would suggest you to please change "Run in the Background" setting to "No" and that will solve this issue. 

    We will wait for your response.

  • Profile Image
    farsheed
    Answered on June 11, 2020 at 07:52 AM

    To answer your questions..

    We have embedded the form on our web-page. however this testing is being done directly on the jotform  url as shown

    The issue is happening across all browsers on all devices we have tested. 

    Please see again.. We have cleared browser cache and jotform cache. 

    But this is what we see now... all widgets are not loading now.

    This is a recurring event every few days. Its not allowing us to clear the form for release testing.

    Please let us know what is happening.

    The URL of the form as shown below is

    https://www.jotform.com/build/201074040056440


    1591876067jotformwid2.gif


    and the URL where the form is embedded is

    https://hd.dorabjeesonline.com/index.html


  • Profile Image
    Sonnyfer
    Answered on June 11, 2020 at 09:27 AM

    Apologies for the inconvenience. 

    I have cloned your form but wasn't able to replicate the issue. Both Email Validator and Random Value generator works fine on my end.

    1591881838clodsds.gif

    Would it be possible for you to clone this form on your account and use it instead so you can move forward? 

    Another option is for us to forward this to our backend team for further checking.

    Let us know how you wish to proceed.

  • Profile Image
    farsheed
    Answered on June 11, 2020 at 10:01 AM

    Hi I've already cloned the form 2 days ago when the issue surfaced again. 

    Today when the issue occurred I checked the cloned form and the same form had the same identical problem as the original form had.

    In fact here's what I did further before I made a ticket. 

    I opened another form where there was no E-mail validator  widget and added a new Email Validator widget there and there to I got the same greyed box as showed in my replies to you. 

    So when the problem sets in it sets in my whole account. Not just one form. 

    As of now Ive just logged in an things are ok and the widgets are working.

    I suggest we wait till tomorrow and if the issues persists tomorrow please take it up with the backend team and inform them that its affecting every form not just one form.

    Please keep this ticket pending till tomorrow.

    thanks 



  • Profile Image
    ashwin_d
    Answered on June 11, 2020 at 10:57 AM

    When you see the issue again, I would suggest you to please test your form again using a different network or test your form in mobile device with mobile network and see if the issue persists. I believe, there must be some network or firewall issue. 

    We will wait for your response.

  • Profile Image
    farsheed
    Answered on June 11, 2020 at 12:15 PM

    Ok fine I will do so and inform you accordingly...