Users not being able to advance in form

  • Profile Image
    drwizo
    Asked on July 07, 2013 at 11:27 PM

    Hello guys, 

    I am having a lot of issues with our forms. Users complain that when they click on next to advance to the next page of the form, nothing happens. I thought that this was caused by Internet Explorer, but have had some users report the same problem in Firefox and/or Chrome. Plus, as much as we all dislike IE, it is still the most popular browser so I need to make my forms accessible to everyone.

    I have not been able to replicate the problem myself but I have been getting that report consistently from my users.

    Could you take a look and try to find out what could be causing the problem? The form is at www.worldstemcellsclinic.com/medical.html

     

    Thank you very much!

  • Profile Image
    Welvin
    Answered on July 08, 2013 at 05:31 AM

    Hi,

    We recommend re-embedding the form using our iframe method: How to Get Form iFrame Codes. Specially, when a problem like this will happen.

    Please try that and let us know for the result.

    Thanks

  • Profile Image
    drwizo
    Answered on July 08, 2013 at 03:26 PM

    Thank you. I did that already. Like I said, I was not able to replicate the issue myself so I hope that this change you suggested will help my users. I will let you know if they still have difficulty.

     

    Thank you!

  • Profile Image
    sidharth_kch
    Answered on July 08, 2013 at 05:19 PM

    @drwizo

    Sure, let us know if the issue persist.

    Thanks,

    Sidharth