Submit and Save button displaces when clicked on Internet Explorer

  • Profile Image
    Ashley
    Asked on June 17, 2020 at 02:50 AM

    Hello,

    I have two troubleshoot items for my form:

    1 - When someone tries to click on the 'submit' button at the end of the form it glitches and jumps away from the mouse click and is very hard to get it to work. 


    2 - On the final successful submission page we have put in the option for the form completer to download a pdf copy of their form. However when they click on this it gives an error message and says the user is not authorised to do so. Please may you help fix this so that the form submitter can have a download of the pdf like the form builder gets?

    Thanks for the help!

  • Profile Image
    JohnRex
    Answered on June 17, 2020 at 05:50 AM

    I have cloned the form and made a test submission to it, but was not able to replicate the issue. The form was submitted with no problems encountered.

    I recorded the transaction so you can check: https://bit.ly/2UOL4I7 

    If you could also provide a recording, we can check and try to replicate the responses you made on a cloned form.

    You may upload it to a cloud drive (such as Google Drive or DropBox) then share the URL here.

    Also, I have moved your last question to a separate ticket. I will be posting my response to that via this link: https://www.jotform.com/answers/2394105 




  • Profile Image
    NRG_Nutrition
    Answered on June 21, 2020 at 06:54 AM

    Hi John

    Thanks for your help.

    Here is a wetransfer link to the error that I recorded. Both the button for S&C and sumbmit are now jumping when you try and click on them. I'm thinking it must be something about where they're positioned / floating etc?

    https://we.tl/t-UHtfHNy9Nt

     

    Thanks

    Ashley 

  • Profile Image
    JohnRex
    Answered on June 21, 2020 at 10:43 AM

    Hello Ashley - It seems the issue only happens when you use Internet Explorer. Using Chrome and Firefox, the submit and save button works fine.

    Let me conduct a few more tests on this and see if there's a possible solution for that.

  • Profile Image
    JohnRex
    Answered on June 21, 2020 at 03:51 PM

    Thank you for waiting, Ashley! So I was able to resolve the issue with IE browsers. Please add this code below to your form:

    https://pastebin.com/Vj52JBXC 

    That should resolve the button displacement when the form is accessed on IE.

    I have implemented this in a cloned form. Please check this form as well so you can try: https://form.jotform.com/201723767441960?jumpToPage=5  

  • Profile Image
    NRG_Nutrition
    Answered on June 29, 2020 at 04:32 PM

    Hi John 

    The form submits all fine now. 

    Thanks so much for your help!! 

    Ashley