I have been trying unsuccessfully to upgrade.