conditions on radio button widget is not working

  • Profile Image
    actismedia
    Asked on August 22, 2020 at 05:13 AM

    Hi - I have this current form 202254886744362

    However, I need a few things to work and I'm not sure I've used the right widget?

    1. When a option in one widget is turned on then another widget is to display and the original widget becomes hidden, then an option in the new widget is clicked on and a new widget displays and the 2nd widget hides, and so on.  Effectively, when the user selects an option in the widget that widget hides and a new one shows.

    The problem is in my firm, all but the first widget is hidden at the start, but, when one shows a widget after a conditional click then this widget shows at the very start?

    2. I need to send a notification by email with the result of a simple calculation.  Currently, the user selects a few buttons and then enters in a figure to get a cost.  I need this info passing, i.e. the square meterage and the cost.  I think I need to add a submit button, but, I need to add a submit button to each and every set (if you see my form there are 40 questions, and the user will only want one or two.

    Effectively, I need a form to...

    1.Show a series of buttons, then
    2.the user clicks on a choice, then another set of buttons appear and the user clicks on a choice
    3. the user then clicks on a choice
    4. next a bit of text with a box to enter a figure and a result box - I need a submit button (I think) to send this info to an email
    5. The user then performs another set of clicks and enters another calculation.

    You see, there are different services on offer and they may want 3 out of the 40 and want to perform 3 calculations.



    The other problem I have with the current form is that when one has completed a calculation and then goes back, one cannot 'deselect' the buttons to go back, so the user ends up in a mess.

    Any help would be great please?

  • Profile Image
    Richie_P
    Answered on August 22, 2020 at 07:11 AM

    1. When a option in one widget is turned on then another widget is to display and the original widget becomes hidden, then an option in the new widget is clicked on and a new widget displays and the 2nd widget hides, and so on.  Effectively, when the user selects an option in the widget that widget hides and a new one shows.

    The problem is in my firm, all but the first widget is hidden at the start, but, when one shows a widget after a conditional click then this widget shows at the very start?

    I see that you're using the button radios widget. Tested your form and it seems to be working at my end.

    May we know what specific button radio widget is having an issue?

    If possible, share a screenshot.

    To post a screenshot, you can follow this guide: -How-to-add-screenshots-images-to-questions-to-the-support-forum

    Looking forward for your response

    For your other questions, I have moved it to a new support ticket to assists you better.

    Kindly follow these links

    https://www.jotform.com/answers/2530038

    https://www.jotform.com/answers/2530039