What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form Changes Lost, unable to auto-save.

    Asked by sbohler on August 07, 2013 at 05:07 PM

    I just spent 3 hours working on a time-critical jotform, clicking SAVE and watching auto-SAVE occur regularly throughout my development session... then my screen flashed and my form changed.  My form is now reverted to what it was this morning.  Many field changes and many rules... poof; gone.

    1 - How do I get this back? 

    2 - Any idea why this might happen? (I did not have the form open in a secon window or tab - I read that can be an issue but not here)

    Help, please.

    JotForm session auto-save 3
  • Profile Image

    Answered by sbohler on August 07, 2013 at 05:31 PM

    I had the correct working form previewed in another firefox tab and saved the HTML file to my computer.  Can this be imported back to jotform?

  • Profile Image

    Answered by sbohler on August 07, 2013 at 05:46 PM

    Ok... I created a new form and imported the previous, correctly displaying HTML (jotform preview) that I had saved to my hard drive (uploaded to my website in order to import from URL).

    When I imported the form it appears exactly like the reverted one.  Wrong fields.  Wrong rules.  It does not look like what I imported.  When I view the imported URL the form displays properly as designed, but it's not finished.

    Very frustrated.  Please help.

  • Profile Image

    Answered by khrisell on August 07, 2013 at 07:49 PM

    Hello,

    We are truly sorry for any inconveniences that it may have caused you.

    Can you provide us the URL or the Title of the Form you are pertaining to so that I can replicate the issue?

    Also, are you experiencing this to a certain form only or persisting to other Forms aswell?

    May I know the method on how you are importing your form?

    I will wait for your response as I am really eager to help you out with this issue and so we could work together in fixing it.

    If it needs escalation to our higher level of support, we will do that. But for now I need the information to further assist you with it.

    Thank you

  • Profile Image

    Answered by sbohler on August 08, 2013 at 07:25 AM

    The title of my form is "Integrated Registration A".  The URL of the saved copy that displays correctly is http://stbohler.com/jotform/Integrated%20Registration%20A%20SAVED%20CORRECT%20VERSION%208.7.2013_3.35pm.html

    When I create a new form and import from this URL the resulting is not correct.

    Thank you

  • Profile Image

    Answered by jefreylandicho on August 08, 2013 at 09:56 AM

    I checked browser history and was able to confirmed your saving processed and the last one was after updating the contact us form. May I know the last changes you made in the Integrated Registration form after updating Contact form?

    Also when the flashed happened, did this occur while the form is in a saving process? Can you also provide us more details on the flashed that you have experience as from the look of it, the saving might have been interrupted causing the form not be saved or corrupted.

  • Profile Image

    Answered by sbohler on August 08, 2013 at 10:10 AM

    Sorry, but I don't remember now what the specific changes I made just then were.

    I don't know if it was during a saving process or not, but I did receive several, maybe 5 or 6, save errors during my session.  When that happened I clicked the notice off and then did a manual save.  The save errors were concerning.  I didn't capture one but perhaps their in your system logs?  They might be revealing...

    Please look into the cause of this problem but don't worry about recreating my form at this point - I've already done that.

    Thanks,

    Scott

  • Profile Image

    Answered by EliezerN on August 08, 2013 at 11:55 AM

    We deeply apologize for this issue.

    I have cloned your form and made some tests to make usre if the issue was related with Jotform or not, but I wasn't able to reproduce the issue, so, probably that was a browser related issue. So I have cleared your forms cache if that is related to something in our system, you should also clear your forms cache from your side.

    To prevent further issues related to this you should clear your browser's caches and cookies

    If this issue appears again in the feature, don't hesitate to contact us.

    Thanks

  • Profile Image

    Answered by sbohler on August 09, 2013 at 05:06 PM

    Thank you for looking into this.

    Scott