Calculation in input table not working when value is ZERO

  • Profile Image
    NCDEX1
    Asked on October 21, 2020 at 03:57 AM

    Please refer my form below. I have used condition in the input table object [127. 1)BO identification]. The conditions work well when the input value is more than zero in either of the 2 fields i.e, "Total Legal Entity (LE) accounts active as on 31/03/2020" and "Total LE accounts for which BO identification as per the latest standards have been carried out as on 31/03/2020".

    However when the value in both these fields are zero the computed value in field "Percentage" is not getting populated.

    Please assist..

    form name: Clone of Internal Risk Assessment of Registered Intermediaries

    Link: https://form.jotform.com/202934232640448


    Page no: Page no 6. - (IX) BO Identification


  • Profile Image
    Richie_P
    Answered on October 21, 2020 at 08:45 AM

    It seems you're using calculations to get the values however, zero values are null when you divide them based on your formula.

    1603284054_5f902c56d0909_1.png

    The total is still correct even without the values showing.

    Looking forward for your response.

  • Profile Image
    NCDEX1
    Answered on October 21, 2020 at 08:50 AM

    Thank you for your inputs. However the challenge here is since the Percentage field is not getting update, the form is not allowing the user to move ahead since it is mandatory field. Is there some way to use the "IF" condition or anything else which can help me populate the percentage field with zero and the form will allow the user to go ahead with the remaining part of the form.

    Regards,

  • Profile Image
    Richie_P
    Answered on October 21, 2020 at 10:13 AM

    Unfortunately, it is not possible to check if the input for the specific table values using conditions.

    You can set the required field to allow at least one answer.

    1603289548_5f9041cc1d0e1_1.png