Not being able to submit forms

  • Profile Image
    ofd@archatl.com
    Asked on September 09, 2013 at 02:00 PM

    I have people trying to fill out my form, uploading a picture, along with their submission, and some of them have come back to me and told me that once they hit submit, the button just says "please wait" and does not submit the information.  What is the problem and what can we do to solve it in the future? 

  • Profile Image
    Welvin
    Answered on September 09, 2013 at 02:53 PM

    Hi,

    A possible conflict might causing this to happen specially when you are currently embedding the form using our Source Codes method (How to Get Form Source Codes) or the Javascript Method. Please try re-embedding your form using our iframe method (How to Get Form iFrame Codes), this should help in many cases.

    Also, we'll be glad to check that if you can provide us the webpage URL to where the form is embedded.

    Thanks

  • Profile Image
    ofd@archatl.com
    Answered on September 09, 2013 at 02:56 PM

    Thanks for testing it out.  I just saw a test submission. 

     

    The form is not embedded.  On the website, they click the link and it points them to

    http://form.jotform.us/form/31564989177168.

     

    Secondly, I just got off the phone with someone who tried to submit it, and once they clicked submit, it just said "Please wait..."

     

    Is it because of the image upload?  I am curious why it works for me, and some of these other people have issues with it working.  

  • Profile Image
    EliezerN
    Answered on September 09, 2013 at 05:29 PM

    Thanks for contacting us.

    Have you already tried cloning your form and testing it if the issue is reproduced on the cloned form? I cloned it, however, I wasn't able to reproduce the issue even when uploading an image, see this video of my test:

    https://shots.jotform.com/eliezer/Screen%20Captures/please_wait_.swf

    If you have not tried, please give it a try to see if the issue is only wiht the original form. Kinldy use this guide to know how to clone a form: How to clone an existing form from a URL

    Let us know if the issue persists even with the cloned form.

    Thanks

  • Profile Image
    ofd@archatl.com
    Answered on September 10, 2013 at 09:56 AM

    A collegue of mine and I thoink we found out that the issue was the size of the image, so we limited it to 1MB.  I will wait to see submissions to see if they have issues.  I did send another ticket about notifications, still having issues with those.  I did not get an email otification when you submitted your test in the video.