Validations does not work when form is embed in joomla.

  • Profile Image
    Fernando
    Asked on September 16, 2013 at 11:07 AM

    Hello, I am using the 2.5.9 version of joomla, when I insert a payment form some options fail, for example: the form does not display the total value and the required fields are not working properly, sometimes appears as frozen. I tested on other browsers and do not work

    please can you help me

    copy the link of the problem

    http://webhostingecuador.ec/index.php/component/content/article/2-uncategorised/40-pago-via-deposito-o-transferencia-electronica

     

    thanks

  • Profile Image
    ashwin_d
    Answered on September 16, 2013 at 11:37 AM

    Hello Fernando,

    Validation and calculation scripts are not working on your form because there seems to be some conflict between JotForm scripts and other scripts of your site.

    I suggest you to re-embed your form using iFrame embed script. This will resolve any script conflicts because this is the reason that your form validation does not work. Here is a guide that should help you grab iFrame code: http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    Do let us know if the issue persist.

    Thank you!

  • Profile Image
    maow001
    Answered on September 16, 2013 at 04:35 PM

    hi, thanks but I'm not sure if that is the reason, sometimes works and sometimes not, I found a similar issue this webpage

    http://sanfranciscoheadshots.com/info/contact/

    Note that that is not my website but seems like have the same issue. As I told you I´m not 100% sure but tha problem appears even in other websites

    ??... =(

  • Profile Image
    Mike_T
    Answered on September 16, 2013 at 04:49 PM

    @Maow001,

    It looks like that the form is conflicting with the jQuery scripts on your page. Please try to use an iFrame version of the form.

    If you need any further assistance on this, please create a new thread. We will be happy to help.