Multiple Conditions not working??

  • Profile Image
    barobinson
    Asked on September 23, 2013 at 10:31 AM

    Hi there,

    I'm creating a registration form for a trip and I need to be able to set up multiple conditions for my fields and it doesn't seem to be working properly. Here's the summary of the form:


    It asks how many adults and how many children, allowing up to 4 of each.

    I'm trying to set up conditions so that if 1 adult is selected, the fields for adults 2-4 are hidden, if 2 adults are selected, fields 3-4 are hidden, etc.
    The first condition seems to work fine but anything following that doesn't seem to work properly. I've tried utilizing both the Show and Hide options, I've tried altering the order in which I have the conditions and it doesn't seem to work.

    My current conditions (only 2 so far) are set up as such:

    1. IF number of adults equals "2", then Hide Adult 3, Birthdate, Adult 4, Birthdate
    2. IF number of adults equals "3", then Hide Adult 4, Birthdate

    What shows up on my preview:
    1. If 2 is selected, it does successfully hide adults 3 and 4
    2. If 3 is selected, all 4 adults are showing

    Any help you can provide would be great!


    Thanks

  • Profile Image
    KadeJM
    Answered on September 23, 2013 at 12:30 PM

    Hi Baro, I just cloned your form to attempt to test this further in regards to your issue to help you more but it looks like you are reworking it still? It seems to me so far that this is now configured and working properly after I tried this again where as before this it I could see it was not working. Please let us know if you are still having issues with this and we'll gladly help you more should you need it.

     

  • Profile Image
    abajan
    Answered on September 23, 2013 at 12:48 PM

    Hi Baro,

    Here's a clone of your form. Is this how you intended the conditions to work? You'll notice that each date field has been prepended with "Adult 1", "Adult 2", "Child 1" etc. When multiple fields on which conditions are to be attached have identical labels, it's best to temporarily rename those labels to ensure that the conditions are not being set on the wrong fields. Then, once you're sure that everything is working correctly, you can reset the labels to their original text.

    The conditions in my clone are set as follows:


    (The screenshot doesn't show all eight [8] conditions but I think you get the idea.)

    If you need further help with this, we'd be happy to help.