Why is my submit button not showing?

  • Profile Image
    dazzyl
    Asked on September 26, 2013 at 06:11 PM

    I switched from captcha to reCaptcha and all the sudden the submit button, it shows up for a hot second then disappears.  I am using the iFrame and have tried changing the height to as much as 1,500px when the form is 1,100px, and that doesn't work.  I've even got a fresh code and that didn't work.  I 've tried it Chrome and Firefox and get the same results. Any suggestions?   I hope I don't have to switch back to regular captcha as I prefer reCaptcha.  Oh! The submit button shows up in the preview.


    Thanks!

     

  • Profile Image
    Tasha
    Answered on September 26, 2013 at 09:08 PM

    Hi,

    To fix this you need to increase the Iframe size for your form. The height of your iFrame is currently 884px, try increasing the height to 950px as shown below. 

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="//form.jotform.us/form/32668394935166" frameborder="0" style="width: 690px; height: 950px; border: none;" scrolling="no"></iframe>

    I tested it in chrome and that fixed the issue. If you are not seeing the change after changing the height please try to clear your browser cache and viewing the page again.

    I hope this helps! Please let us know if you have any further questions.

    Thanks!

  • Profile Image
    LifeUniverseThings
    Answered on September 26, 2013 at 10:05 PM
  • Profile Image
    dazzyl
    Answered on September 26, 2013 at 10:10 PM

    JotForm Support,

    I had thought of something else before I got your replay.  I iFramed the direct link and all is well now.  Thanks for your help.