Jotform PDF Editor::The PDF documents template are not coming with the cloned form

  • Profile Image
    reneelatour
    Asked on December 07, 2020 at 08:50 AM

    I was able to get this to work, but the other user doesn't have access to the PDF's associated with the form. When they go to PDF editor, there's nothing there :(



    This is a re-post of a comment on How to Clone an Existing Form from a URL

  • Profile Image
    Katherine_W
    Answered on December 07, 2020 at 11:54 AM

    Hi there,

    Happy to help!

    Could you please provide some clarification around the issue your user is facing? When I look in your account I see two sub-users: one has forms shared with full access and the other has no forms shared with them. Could you please specify which user is experiencing the issue?

    Upon cloning your form 203177140833046, I did have to create a New PDF in the Form Editor: could you please confirm that this is the form URL that you are experiencing the issue with? If not, please provide us with the correct form URL. Here's where-to-find-my-form-url

    May we have your permission to access the original form to investigate fully?

    We await your response.

  • Profile Image
    reneelatour
    Answered on December 08, 2020 at 04:00 AM
    You have my full permission to access my account to see what's going on.
    The second account I'm using under renee.latour@yahoo.com is a dummy
    account that I am testing the functionality of the cloning and PDF
    templates. Here are the issues listed out:
    1. From my account, reneelatour I'm allowing cloning of these two forms
    (URL's):
    https://form.jotform.com/reneelatour/lease-finance-quote
    https://form.jotform.com/reneelatour/credit-application
    I'm giving instructions to other Jotform users to clone these forms,
    following Jotform's instructions and I'm providing them with the URL's
    above.
    When they clone the form, the PDF's do not clone.
    https://form.jotform.com/reneelatour/lease-finance-quote
    - Should have the following PDF's:
    https://www.jotform.com/pdf-view/017c807249
    https://www.jotform.com/pdf-view/be1f1cd3c8
    https://form.jotform.com/reneelatour/credit-application
    - Should have the following PDF:
    https://www.jotform.com/pdf-view/f1a2cad30e
    2. Workaround for issue with #1 - I'm creating public templates for the
    users to add the PDF's above to their cloned forms. I'm providing them
    instructions on how to add these PDF templates to their newly cloned forms.
    When the PDF's are added, there seem to be several glitches that change the
    PDF data and jumbles it up. There doesn't seem to be anything wrong with
    the PDF templates or the cloned form, so I'm not sure what the issue is.
    Here's a screenshare of what's going on:
    https://vimeo.com/488436107/0bbc6889f7
    ...
  • Profile Image
    Richie_P
    Answered on December 08, 2020 at 05:41 AM

    I would suggest using the Form URL instead of the custom form URL in cloning the form.

    Guide:https://www.jotform.com/help/401-where-to-find-my-form-url?

    You can select PDF document templates in the PDF editor.

    Go to Layout settings>Templates and select the template category you have added to the public template.

    1607424046_5fcf582e8aa8a_2.png

    Please give it a try and let us know if the issue still remains.

  • Profile Image
    reneelatour
    Answered on December 08, 2020 at 06:55 AM
    Hello,
    I've already done both of these steps, changing the URL doesn't make a
    difference, I've tried it both ways. That is how I'm creating the PDF
    templates as well. Are you seeing the issues with the PDF templates that
    are attaching? Do you need me to explain this further?
    ...
  • Profile Image
    Fernand
    Answered on December 08, 2020 at 08:21 AM

    Hello reneelatour,

    We are sorry for the inconvenience. I checked both forms and tried to clone them as you show in the video. However, the PDFs are not cloned. That's why a bug ticket has been created and escalated to our developers. We cannot provide an ETA on the issues fixed. However, you will be notified when it's fixed via this thread.

    In the meantime, when I tried your workaround and send a submission, it seemed the jumpy fields disappear.

    1607433028_5fcf7b44c0fdf_Screen Shot 202

    However, as I said above a bug ticket has been created and escalated to our developers.

    Please have a check and let us know for further assistance.