Form: submit button is not working

  • Profile Image
    RyanHorsak
    Asked on December 18, 2020 at 04:17 PM

    I have been having SOOO many instances where a user will submit my form successfully and then they try again the next day and the form submit button will not work for them. This has happened to me as well.

    I have tried everything: cloning the form, building a brand new form from scratch, deleting the submit button and and adding a new submit button, clearing my browser's cache and instruction others to do so, using different web browsers


    I have tried it all. What is going on? Why is the submit feature sooooooo sporadic and cantankerous?

    How can I fix the glitch?


  • Profile Image
    Lorenz_A
    Answered on December 18, 2020 at 08:05 PM

    Hi there,

    I've checked your form and the unique submission is currently not configured so it shouldn't prevent previous users to submit the form again.

    I cloned your form and I was able to replicate the issue, it won't let me submit the form on the first try. I have escalated this issue to our back-end team to further check the problem.

    We'll keep you posted via this thread for any updates.

    Thank you.