What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    users saying they've submitted but submissions not there...

    Asked by skyrun on October 16, 2013 at 05:36 PM

    i'm new to jotforms and put up my first form just yesterday.  i've gotten quite a few submissions, but have had 2 users call to say they submitted and didn't get an error, but their form is not showing as being submitted.

    not sure how to troubleshoot it... does this happen on certain browers?  have you ever heard of this happening?

    Page URL:
    http://www.skyrun.com/share-your-story

    Submissions
  • Profile Image

    Answered by jedcadorna on October 16, 2013 at 07:51 PM

    Good day,

    I can see that the form was submitted, what the problem could be is that you weren't able to receive the notification that the form was submitted.

     

    Form submitted:

     

    Email notification settings:

    1. Click on Email Alerts | Notification | Reply - To and Recipient Settings then add fields under Sender Name. Fields under Sender Name will depend on what fields you put into your form, so you might have a long list of selection when choosing a sender's name.

     

    Please let us know if this helps you fix the issue.

    Thanks,



  • Profile Image

    Answered by skyrun on October 16, 2013 at 07:55 PM

    no, that's not it.  the ones you point out are other submissions.  the ones my users are complaining about are not there.

    anyway, i think i figured out at least one thing that was causing it.  there is a bug in jotform that image validation doesn't work on IE10 (the latest version).  so the form doesn't submit.  pretty significant bug... hope it can be fixed soon.  forms don't submit but users don't know.  of course i don't know since i do get the submission either.

    i put another forum post in for that bug.

  • Profile Image

    Answered by jedcadorna on October 16, 2013 at 08:05 PM

    Hi Skyrun, I have responded to you via this thread with regards to your issue with IE.