What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    issues with using form on different browsers

    Asked by UoNSU on November 06, 2013 at 11:18 AM

    Hi

     

    I am experiencing some problems with my form http://www.jotformeu.com/UoNSU/Event_Approval__Form in that when viewd on diffrerent browsers the conditional options for drop down boxes on page 1 don't seem to work - in addition users are unable to move on to the next page as the next button doesn't work.

    Here is a screen shot using safari on my ipad. this problem also appears to be happening on chrome and IE and firefox sporadically and means that users are unable to complete the form so it's a big issue for us.

    It is worth saying that it only appears to be a sporadic problem - it works on chome on my browser now but didn't earlier.

    Page URL:
    http://www.jotformeu.com/UoNSU/Event_Approval__Form

    Screenshot
    using form different problem ipad next www
  • Profile Image

    Answered by jedcadorna on November 06, 2013 at 12:01 PM

    @UoNSU,

    I'm unable to replicate the issue on my end here's a video sample using 3 different browsers. The only problem that I found was when using Firefox you have to manually click the option unlike when I tried using IE and chrome you can use your arrow keys to select option and the condition will just follow also I was able to go to the next page using 3 different browsers. Have you tried clearing your browser's cache and see if it somehow helps?

    1. Using IE - http://screencast.com/t/JKConK4A

    2. Using Chrome - http://screencast.com/t/yALTSljZ2

    3. Using Firefox - http://screencast.com/t/hvgU2ngfXcTc

     

  • Profile Image

    Answered by UoNSU on November 06, 2013 at 12:08 PM

    have cleared the browser cache on safari on ipad and it is still occuring.

    This is a wider issue though as I cannot expect every one of my users to follow that advice to fix the problem can I?

  • Profile Image
    JotForm Support

    Answered by KadeJM on November 06, 2013 at 12:30 PM

    Okay, sorry about that and thanks for trying this on your end. It is understandable with what you mean about not everyone following the same suit to fix it. However, unfortunately it can be said that depending on the user software and browser being used on a person's iPad the same problem can become an end result but we will try our best to help resolve it for you. We will also do what we can on our end to help you with fixing this.

    Is all happening on iPad? Correct? Or?

    Are you using the latest iOS (iOS 7.0.3) on your iPad? Or? 

    Are you using the latest Updated Mobile Browsers on your iPad?

    Also, which iPad Generation are you using?

  • Profile Image

    Answered by UoNSU on November 06, 2013 at 12:39 PM

    it is not just an ipad issue - i tried it on a laptop earlier in chrome and in firefox and had the same issue

    on my ipad i am using the latest versions of everything - iOS7 and updated safari - it is an ipad2

  • Profile Image

    Answered by EliezerN on November 06, 2013 at 01:21 PM

    Thanks for providing the information above.

    I also tested your form, but I was not able to reproduce the issue with the conditions nor with the Next button.

    I tested on Chrome and using FireFox. So, in order to resolve this issue I proceeded to clear your form caches from our side, that might help to resolve this issue. You can also do it from your account too, ust follow the next guide: How to clear your form cache

    So, please make a test and let us know if that works or if you need further assistance. If you need assistance with something else kindly open a new thread.

    Thanks