Iphone edit function not appearing for offline forms

  • Profile Image
    miketheqs
    Asked on February 11, 2021 at 08:33 PM

    Hi Jotform,

    I am having some issues with a form I have built, seems to be specific to Iphones.

    We have a form titled "Version 2 MCG site inspection sheet" that seems to work perfectly fine with Android users (Eg, my Samsung Galaxy works just fine) but then the edit form functionality is just outright missing when using the same form with an Iphone.


    I have attached an image of what I see, there is a little square with a pen in it that indicates the "edit form" function. This is missing from all Iphones that try to use this application.


    Is there any real reason for this, or a known workaround? our entire workforce uses Iphones so this is hindering the ability to do things digitally as we had intended.


    Thank you Jotform!



    Screenshot
  • Profile Image
    Rehan_F
    Answered on February 12, 2021 at 01:46 AM

    Greetings,

    Kindly clarify if the edit option is not appearing when you are using the forms offline? Or it doesn't appear when you are connected to the internet as well?

    Is it occurring in only one form?

    https://www.jotform.com/form/203416770993866

    Did you encounter this issue in other forms as well?

    Looking forward to hearing from you.

    Thanks

  • Profile Image
    miketheqs
    Answered on February 14, 2021 at 05:01 PM

    Hello,


    It doesn't appear at all. Online, Offline, doesn't seem to matter with the Iphone.


    Having said that the vast majority of the testing done was on an Iphone with airplane mode on, and again without airplane mode but no Wifi or Data to simulate offline only. Androids had no issues doing this, but the 3 Iphones we tested this on worked right up until going back out of the form, saving the submission and heading back to the submission area. The saved form does indeed show in the submissions area, but there is no action to take beyond that except for resubmitting. The edit form button just doesn't exist for Iphones on our form.


    We have so far tried it on both of the MCG inspection sheets and neither seemed to work.


    Thanks

  • Profile Image
    gerardw
    Answered on February 14, 2021 at 11:08 PM

    I have been testing few demo forms and also a cloned version of your form on an iPhone but I am unable to reproduce this issue.

    I was able to view the edit icon on the iPhone. It tested this on an iPhone XR (iOS 14.3) - iOS app 1.15.7:

    1613361974_6029f33692961_Screenshot 2021

    After editing, I was able to view the edited data too:

    1613361999_6029f34f0d314_Screenshot 2021

    Please let us know the iPhone models and the iOS versions you were testing on. Please also use the latest version of the iOS app i.e. version 1.15.7 and then check.