Voice recorder widget: audio loss when recording a single tone

  • Profile Image
    mysteriacare
    Asked on February 19, 2021 at 07:01 AM

    Dear Jotform Team,


    We have started using the voice recorder widget in one of our forms and we are encountering two kinds of problems.

    We ask for people to submit a 10 second recording of their voice, doing a continuous "AAAAAAA" sound.

    For most recordings, the sound level systematically drops after 4 seconds.

    (example : https://eu.jotform.com/widget-uploads/voiceRecorder/210312149293347/60297520ccc41_161332969660297520d2cec.wav)


    For other recordings, the sound seems so compressed that nothing can be heard.

    (example : https://eu.jotform.com/widget-uploads/voiceRecorder/210312149293347/602ee1851ce81_1613685125602ee1854c167.wav)


    Is this a known issue and is there a fix for this ?

    Also, is it possible to configure the widget so as to have pure, uncompressed PCM recordings ?


    Thank you and kind regards.

  • Profile Image
    Richie_P
    Answered on February 19, 2021 at 09:25 AM

    I have tested a cloned version of your form and I am able to replicate the issue at my end.

    It seems the voice recorder losses the audio after 4 seconds when you hold a tone for a period of time however, when you say the words normally, then the recorder is working.

    I have escalated the issue to our back-end team for further investigation.

    Once we have updates, you will be notified at this support ticket.

  • Profile Image
    mysteriacare
    Answered on February 22, 2021 at 07:01 AM

    Hello Richie,

    Thank you. From the other submission we're getting, it seems that while the output file is a WAV, the recorded sound is heavily compressed to the point where it sometimes become even inaudible.

    Would there be a possibility to record pure uncompressed and unprocessed raw audio and to save it as is, without alteration or post-treatment ?


    Thank you and kind regards,

    Alain

  • Profile Image
    KrisLei
    Answered on February 22, 2021 at 07:17 AM

    Hello Alain,

    Let me also forward your query to our developers as I can see that my colleague has escalated this ticket to them. We will provide you with any updates as soon as we hear back from them.

    Thank you.

  • Profile Image
    hayk
    Answered on February 23, 2021 at 08:07 AM

    Hi Alain,

    We are sorry for the inconvenience caused to you. We have updated the widget and the issue has been resolved. The widget's sound level is not getting dropped after the 4th second anymore when you record a single tone. Please clear your browser's cache and check out the widget once again. Thank you for reporting the issue.

    Regards,

    Widgets Team