What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Users are clicking the "Submit" button but it isn't taking them to the thank you page

    Asked by GetPreparedStuff on June 08, 2011 at 11:56 PM

    I've had a form that worked for some time but lately people have not been able to get it to work.

    The form http://www.jotform.com/GetPreparedStuff/SunOven has a submit button that is not functioning all the time. When clicked on it should take you to the thank you page but in the last month very few have seen this occur.  When the button is clicked it simply gives them a please wait type of message and leaves them on the main form. No thankyou page is shown and no emails sent.

    I don't know if it's related but the images on the same form dissapeared too. The two images had been uploaded to the jotform site but when checked this past week they were not showing up and were not listed in the images available. It was completely empty of any uploaded pictures.

    Page URL:
    http://www.jotform.com/GetPreparedStuff/SunOven

  • Profile Image
    JotForm Support

    Answered by NeilVicente on June 09, 2011 at 04:21 AM

    Hi,

    Did you just re-upload the images or have they been there all along? I checked your form and the images seem to be working fine. I see two images displayed at the top of your form. Can you please check it out for yourself and tell us if the problem still persists?

    I did some tests on your form to confirm if the problem about the non-working submit button is still existing. I couldn't replicate it using Firefox and Chrome. I found out that the problem happens when using IE.

    Upon further investigation, I found out that it is your free text field that causes the problem with the submit. For some reason, that html field contains <form> tags. As it would not happen to appear by itself, it is most likely that you have unknowingly copied a whole form's source code and pasted it on the html field.

     

    The solution now is to recreate that free text field. Clear all the html codes in that field and then start anew.

    If you need further assistance regarding this, feel free to contact us again. Thank you.


    Neil