ISSUE with Analytics "submit.jotform.co / referral"

  • Profile Image
    licciar
    Asked on December 05, 2013 at 09:27 AM

    Hi there, this is my problem. My analytics/adwords account are correctly linked and work properly.

    When a conversion occurs, the "google Analytics" platform correctly tracks it but it says that the origin is, most of the times,  "submit.jotform.co / referral" and of course I can't track properly the correct origin which is 100% coming from adwords.

    Is there any way to see directly the conversion coming from adwords without using the "multichannel conversions tool" which is a bit less accurate?

  • Profile Image
    licciar
    Answered on December 05, 2013 at 10:49 AM

    I'll try with this http://www.annabelhodges.com/proseo-seminar-favourite-things/

  • Profile Image
    EltonCris
    Answered on December 05, 2013 at 12:21 PM

    Hi,

    This might be due to the fact that every form submissions is processed on submit.jotform.com sub-domain. How about changing your default thank you page to Custom URL and append the following URL parameter, this should override submit.jotform URL.

    ?utm_nooverride=1

    Example, if your custom thank you URL is http://www.yoursite.com/thankyou.html, it'd become:

    http://www.yoursite.com/thankyou.html?utm_nooverride=1

    Check this visual guide:

    Let us know if this doesn't help. Thanks!

  • Profile Image
    ryanforrest
    Answered on January 05, 2014 at 11:03 AM

    EltonCris, I tried that and have had many submissions come through since (it's been a few months since I installed it). It is not working :( Any other thoughts?

  • Profile Image
    ryanforrest
    Answered on January 05, 2014 at 11:15 AM

    I think that the ?utm_nooverride=1 code may need to go on the initial submit.jotform.com url as opposed to the thank you page url. Is there a way to append that?

  • Profile Image
    Jeanette
    Answered on January 05, 2014 at 01:08 PM

    The only way to do this is by downloading the source code of the form and finding  submit.jotform.com URL to append  ?utm_nooverride=1 at the end.

  • Profile Image
    ryanforrest
    Answered on January 05, 2014 at 05:46 PM

    Thanks Jeanette,

    It looks like going the source code embed route causes the captcha to break. I've tested it on a few browsers and it appears to just continue trying to load. Have you experienced that as well or is this maybe just a temporary glitch?

     

    Ex:http://www.zagar.com/REQUEST-INFO-s/1822.htm and http://www.zagar.com/Request-For-Quote-s/1845.htm

  • Profile Image
    Welvin
    Answered on January 06, 2014 at 01:26 AM

    Try to save the Form Source Codes into an HTML file. Upload this HTML File to your server and use it as an iFrame to your page. You can generate iFrame using this website: Online iFrame Generator - iFrames Generator. This should work. If not, inform us here.

    Thanks