What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Can't embed form in Google Sites

    Asked by GFPat on June 22, 2011 at 12:11 PM

    I have tried both ways to embed my form on my Google Sites. Neither works. Both methods - clicking the Google Sites button and the iframe - all I get is the frame, not the text, boxes, etc. When I preview the work using the Google Sites button, it shows a portion of the form. Even scrolling down, the whole form is not there. 

    You guys have an awesome service. I've submitted several questions, and your answers prompt beyond belief! You've always been able to help me too, either suggesting a fix or a work-around. Hope you can help me with this one too. 

    I'm not sure providing a URL or screenshot will help you. If you need either, tell me specifically which URL or which screenshot you need.

    GFPat

  • Profile Image

    Answered by allanftd on June 23, 2011 at 02:11 PM

    Hi GFPat,

    As previously recommended in a separate thread, please use the Iframe embed code but make sure that you are targeting the correct form URL in the iframe:

     

    <iframe allowtransparency="true" src="//www.jotform.com/form/11700014293" frameborder="0" style="width:100%; height:478px; border:none;" scrolling="no">
    </iframe>

     

    Note that you can change the iframe height (value highlighted in green) in order for the browser to show all of your fields. Otherwise, the scrolling attribute of the iframe should be set to "yes".

    Please let us know how it goes. Thank you for using JotForm!

    JOTFORM SUPPORT