What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Urgent! Form Won't Advance to Page#2!

    Asked by RogerYelvington01 on January 07, 2014 at 10:26 AM

    Last night, both forms at each of my businesses were working perfectly.  This morning my employees called me because the forms will not move to page#2  It is stuck on the first page, and will not go to "next" on any browser or any computer.

    This is extremely frustrating, because I put time to build this system out.  And I keep having issues - if I cannot have a reliable system that works for everyday business then this whole service makes no sense.

    http://forms.atfgyms.com/form/40047083084146
    http://forms.atfgyms.com/form/40054907336149

     Please advise, as my employees are sitting there today (and we have run a large sale) and they are unable to use the sales form! Thank you.

     

    Roger

     

    Page URL:
    http://forms.atfgyms.com/form/40047083084146

    next move then and
  • Profile Image

    Answered by RogerYelvington01 on January 07, 2014 at 10:50 AM

    So far I have researched and tried these solutions, but none have worked:

    Cut and paste the free text HTML on page one as "plain text"

    Cloning the page

    Clearing the cache in the browser

    Clearing the cash in jot forms account

    Disabling the progress bar
    (starts with 0% completed, and shows 0 fields populated, when normally it shows 46 fields)

    Please help - I just rolled this out to all of my employees and now they think this is not a good solution for them since on the second day using it, it doesn't even work.

     

    Thank you,

    Roger

  • Profile Image
    JotForm Support

    Answered by abajan on January 07, 2014 at 11:00 AM

    Hi Roger,

    I don't know what could have caused this but when I cloned the form and replaced first page break with a new one, it worked. Doing so also corrected a couple other issues: The "Back" button on the first page became hidden and the progress bar was shown. So, at this juncture the best advice I can give you would be to just replace the first page break while we investigate if the issue is isolated to just that form or just your account or if it's system-wide.

    I also noticed that the buttons in each page break are too close to each other and misaligned. I'll see how best to correct that but for at this point functionality is more important than style. I'll get back to you with a solution to properly space and align the buttons as soon as possible.


    Thanks

  • Profile Image

    Answered by RogerYelvington01 on January 07, 2014 at 11:08 AM

    Hi Abajan,

    I cloned the same, with no results:

    http://forms.atfgyms.com/form/40064793936967

  • Profile Image

    Answered by tmi on January 07, 2014 at 11:15 AM

    Team,

    This can be a cloudflare issue. I am facing downtime and 524: Timeout errors in my forms also. Check on priority. Submissions are happening to DB but thank you page and emails are not happening. Check BRL***YPCampus*** letter form activity

  • Profile Image

    Answered by RogerYelvington01 on January 07, 2014 at 11:18 AM

    Thank you for weighing in, but I"m not sure what you mean about checking on priority?  Also, I can't check if my submissions would be going through, as I cant progress to the page where the submit button is located.

    Also not sure what BRL YPCamputer letter form activity is.

  • Profile Image

    Answered by tmi on January 07, 2014 at 11:19 AM

    Sorry Roger,

    I am also a user. I just responded to the thread. Starting a new thread now. Apologies.

  • Profile Image
    JotForm Support

    Answered by abajan on January 07, 2014 at 11:20 AM

    @tmi

    That would certainly be appreciated. Nevertheless, thanks for the info.

  • Profile Image
    JotForm Support

    Answered by abajan on January 07, 2014 at 11:22 AM

    Roger,

    I'm currently preparing a ticket for your situation. There seems to be more issues connected with the form's page breaks than I initially thought.

  • Profile Image

    Answered by RogerYelvington01 on January 07, 2014 at 11:35 AM

    Abajan,

    More info for you - I took away the page breaks, and the form submitted.  However, the fields didn't recognize any of the calculations.

    Is there a way to clone these agreements with new formatting?  I just signed up for premium service, and now I am nervous about the reliability of these jot forms.  When can I expect to hear back?  My businessese rely heavily on these forms.

     

    Thank you,

    Roger

  • Profile Image

    Answered by EliezerN on January 07, 2014 at 02:20 PM

    @Roger

    Please acccept our sinceres apolopgies for the inconveniences this may have caused.

    After cloning one of your form I realized that the cause why the Progress bar does not appear and the Next button does not work are not the pagebreaks themselves, but the Text fields you use in the firs page.

    It seems that the issue appears when more than one Text fields are used in the same page:

    I deleted one and then tested the form, then the progress bar and the Next button worked.

    So I have updated the ticket my colleague opened so that our dev team can find a prompt solution to this issue.

    We cannot give you an specific date when this will get resolved, but rest assured that once it is resolved we will update you via this thread as soon as possible.

    Thanks 

  • Profile Image

    Answered by RogerYelvington01 on January 07, 2014 at 02:47 PM

    EliezerN,

    Even after completely deleting both text boxes from the field as suggested - I am still showing the issue on my side.

    Also, it worked perfectly last night - and I made not additional changes to the form or format from the time it worked, to the time it started working.  This seems so unreliable.

     

    Roger

  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on January 07, 2014 at 04:07 PM

    The issue should be fixed now. Please clear your browser's cache and let us know if the issue persist

  • Profile Image

    Answered by RogerYelvington01 on January 07, 2014 at 04:51 PM

    Jeannette - thank you!

    Can you please tell me what caused this, and how I can avoid this (or any other) issue with these forms in the future.  I am using this for all my businesses and the reliability is so important!

     

    Roger

  • Profile Image
    JotForm Support

    Answered by kenneth on January 08, 2014 at 11:48 AM

    Hi, just want to let you know that this should be fixed now. 
    Its just a server glitch but we manage to give it a solution.
    There's nothing to worry about anymore.

    Please let us know if you're going to experience the same problem again

    Thanks,
    Kenneth