Conditions do not seem to work properly...

  • Profile Image
    BenDMVam
    Asked on January 08, 2014 at 04:54 PM

    The system does not seem to follow the settings in "conditions" pertaining to submit buttons or page breaks... why?

     

    I have a form with 2 pages, one for contact info, the other for order info.

    I have a submit button on page one just prior to the page break ("next button")

    dependent upon the answer to a drop down question on page one, I would like one of the "submit" or "next" button hidden and the other visible (if the answer to the drop down isn't an acceptable one, no further info is needed and the user should be able to simply "submit" instead of going to page 2... if it is acceptable, the user should not be confused by a "submit" button on page one when there is a second page to be completed)

    How can we make this work? Why don't conditions seem to apply to page breaks and submit buttons (they both show all the time)?

  • Profile Image
    Mike_T
    Answered on January 08, 2014 at 06:45 PM

    Thank you for contacting us.

    It seems that the Show/Hide conditions are conflicting between each other on your form.

    We can actually try to use Show conditions to hide the form fields in specific conditions. I have cloned your form and applied the following conditions:

    Example:

    http://form.jotformpro.com/form/40077251967964

    Is this something that can work in your case? You can Clone the form to check it out in the editor.

    If you need any further assistance, please let us know.

  • Profile Image
    BenDMVam
    Answered on January 08, 2014 at 07:02 PM

    This works!...

    Thanks!