When viewing a form in the table view online, the autonumber field does not populate when adding records.

  • Profile Image
    Tony_tlee
    Asked on June 11, 2021 at 06:05 PM

    Hi there! When viewing a form in the table view online, the autonumber field does not populate when adding records; is there a way to make that work?


    Thanks

  • Profile Image
    Jed_C
    Answered on June 11, 2021 at 09:25 PM

    I can see the purchase order column in your tables. Can you clarify what tables online are you referring to?

    1623461111_60c40cf745c1c_Purchase Order

  • Profile Image
    Tony_tlee
    Answered on June 14, 2021 at 10:38 AM

    What I mean is if you use the table view to add a new record, the autonumber field will not populate. It only populates if you use the form to add new data1623681721_60c76ab9b15d0_Capture.JPG

  • Profile Image
    Michal_S
    Answered on June 14, 2021 at 11:46 AM

    Hello!

    This value is generated by the Unique ID widget of the form - to generate the number, the form must be opened and submitted, so when adding a submission without opening the form (like from the submission table), the number doesn't generate and thus stays empty.

    If you'd like to add your own submissions, you can simply fill out the form yourself instead of adding a record in the table - it will function exactly the same, except the number will be generated - if you'd like to modify it later you can do that in the Submissions Table.

    Please let us know if you require any further assistance.

    Thank you!