[Google Chrome 32] Bug: Jotform Form Interface Broken

  • Profile Image
    markashton
    Asked on January 16, 2014 at 08:00 AM

    Sigh ....

    Jotform > form view  ....

    Working on a form ... scroll down ... the toolbar incoveniently duplicates itself right across the godam form elements ... needs fixing ... can't do dick with it like that ... have you been tinkering again and then not testing the changes??

    Browser: Chrome ...

     

  • Profile Image
    Cesar
    Answered on January 16, 2014 at 01:31 PM

    Apologies for the inconvenience this may have brought you.
    Kindly try updating to the latest version of Chrome: Google Chrome - Version 33

    This should take care of the problem.

    Do let us know if you need further assistance. Thank you.

  • Profile Image
    markashton
    Answered on January 16, 2014 at 01:45 PM

    I don't update Chrome ... it updates itself.

    Also, it states in the browser that it is up to date ....

     

    You run a SAAS service ... it should work in the latest and recent legacy browsers 

    Why has this happened? You been screwing around with it and not testing in browsers as usual?

    Mark

  • Profile Image
    Mike_T
    Answered on January 16, 2014 at 05:05 PM

    We have reported the issue to our Development Team. However, that bug is not about the JotForm updates, since the issue is not appearing in Chrome 31 and 33, it is most likely that something is wrong with Chrome 32. At any rate, we will see if we can apply some temporary fix.

  • Profile Image
    markashton
    Answered on January 18, 2014 at 10:55 AM

    Right ... Chrome 33 is in Beta ... 

    So Jotform is buggy in the latest version of Chrome that the layperson ~ 99% of the world ... will be using.

    This is not acceptable .... the main toolbar obscuring fields in the jotform form builder so that they can't be edited ..... forget working on widgets ... forget working on apps ... get the core product stable in the major browsers so that we can use the goddamn thing .....

     

     

     

    Mark

  • Profile Image
    jonathan
    Answered on January 18, 2014 at 03:22 PM

    Hi Mark,

    The issue had been reported and already assigned to a developer. The latest issue you mentioned do happens on Chrome v32 for long forms. I was able to reproduce that issue on Chrome v32. But NOT in Firefox browser though. Using FF, the same multi-toolbar whacked in the form does not happen.

    I have mentioned this findings in the bug ticket.

    We will notify you for any updates when available.

    Thanks.

  • Profile Image
    kencredible
    Answered on January 18, 2014 at 03:37 PM

    Yes I had the same issue yesterday out of no where on a longer form

  • Profile Image
    TitusN
    Answered on January 18, 2014 at 04:18 PM

    @kencredible

    Please open a new thread here so that we can assist you effectively.

    Thank You.

  • Profile Image
    markashton
    Answered on January 19, 2014 at 06:04 AM

    @TitusN

    Why should he open a new thread for exactly the same phenomena ... that's ridiculous.

  • Profile Image
    liyam
    Answered on January 19, 2014 at 07:27 AM

    Hello, Mark. I understand the concern.  However, the team tries to observe the issue into a quantitative perspective which is why they recommend for each user to start a new thread even if the issue observed by different users are similar. Nonetheless, we're addressing each concerns to the best that we can

    Feel free to let us know if you have other questions or concerns.

    Thanks.

  • Profile Image
    abajan
    Answered on January 19, 2014 at 10:59 AM

    Hi Mark,

    This is to inform you that the issue has been fixed.

    Again, our apologies for any inconvenience caused.