What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form-"Initialization" won't work sometimes

    Asked by jenspepie on January 22, 2014 at 03:56 AM

    Sometimes after loading the form (embedded here: http://2big2fail.de/antrag.html) invisible objects (images, should activated by selection of a radio button; see screenshot state_0.png) are shown. The "Back"-Button ("Zurück" in my form) from the page break control is shown too.

    To get the proper initialization state it helps to refresh the browser. It doesn't depend on the browser - it's the same behavior for Safari (Mac), Firefox and Chrome (Win/Mac).

    So how can I get rid of that?

    Thanks!

    Regards Jens

    Page URL:
    http://2big2fail.de/antrag.html

    Screenshot
    png Selection refresh thanks
  • Profile Image
    JotForm Support

    Answered by NeilVicente on January 22, 2014 at 06:16 AM

    Hi Jens!

    Thank you for contacting us. As for your issue, can you please kindly try using the html codes on this link instead?

    http://pastie.org/pastes/8656756/text

    I suggest you test the page on different browsers to see if the fix works well.

    Let us know how it goes for you.

    Best

  • Profile Image

    Answered by jenspepie on January 22, 2014 at 08:03 AM

    The same behavior. Tested in Safari/Firefox/Chrome. All the same. First, there are the three images visible. Then - after refreshing - the form is ok and none of the images will be shown.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on January 22, 2014 at 08:06 AM

    To me it seems that the scripts aren't being loaded for the first time. This could have been a cache issue, if it does not occur on different browsers.

    Still, kindly try clearing your browser's cache. If it does not help, try restarting your internet connection, if possible.

    We'll be looking forward to your results.

  • Profile Image

    Answered by jenspepie on January 22, 2014 at 09:03 AM

    Fixed: Cleared the cache in different browsers/OS, restarted them and the form shows up like needed. 

    Thanks & Regards
    Jens