Pagebreak not working properly in the first page load (have to refresh browser to make it works)

  • Profile Image
    Chaipond_p
    Asked on July 01, 2011 at 10:48 PM

    Hello support team,

    i created 2 forms with pagebreak and used it in secured mode. i noticed that sometime when we open the page at the first time (clear all browser caches) here is the problem

    - Back Button should never appear on first page break
    - Next button is not working
    - refreshing browser will overcome this problem

    can you look at this problem and advice how to fix it?

     

    my form id

    https://www.jotform.com/jsform/11802918210

    https://www.jotform.com/jsform/11805834238

  • Profile Image
    chaipond_p
    Answered on July 01, 2011 at 10:53 PM

    sorry giving you a wrong url. here is correct url

    https://www.jotform.com/form/11802918210

    https://www.jotform.com/form/11805834238

  • Profile Image
    NeilVicente
    Answered on July 01, 2011 at 11:14 PM

    Hi,

    I tested your form using the four most popular browsers today (IE, Firefox, Chrome, and Safari). So far I had no problems viewing your form except Safari.

    Then again, I remember that I have disabled JavaScript in my Safari browser. So I immediately turned it on and the problem is gone. In conclusion, your browser most likely has JavaScript disabled. Please enable it and get back to us if the problem still persists. Refer to the links below to learn how to enable JavaScript in different browsers.

    Firefox
    IE8

    Chrome

    Safari

    Please update us on your progress. We look forward to your response.


    Neil

  • Profile Image
    allanftd
    Answered on July 01, 2011 at 11:30 PM

    Hi chaipond_p,

    In addition to what Neil has mentioned, let me add that this issue could also be related to how fast your browser can translate the whole form. The form code is pretty long (multiple sections, not to mention the banner images) and consider that your browser reads each line from top down. Hence, it sometimes takes time for it to display the form correctly. This is largely dependent on the browser used and your internet connection, beyond JotForm's control. But it should not happen all the time to all users.

    Please let us know if you have any other questions or concerns. Thank you for using JotForm! 

    JOTFORM SUPPORT

  • Profile Image
    chaipond_p
    Answered on July 02, 2011 at 08:49 AM

    Hi, i found the resolution,  Using <iframe> instead of standard embed (<script>) can fix the problem.

  • Profile Image
    allanftd
    Answered on July 02, 2011 at 08:59 AM

    That's nice to know, Chaipond_p. The iframe embed code is a safe choice because it doesn't use any <script> tags and prevents your form elements from interacting with your website's scripts. Please let us know if we can be of further help to you.

    Thank you for using JotForm!

    JOTFORM SUPPORT

  • Profile Image
    pandcproductions
    Answered on September 24, 2012 at 05:17 PM

    I have a similar problem but it is with the form collapse tool.  About 75% of the time it does not load properly and becomes sort of "frozen" making the form not responsive to mouse clicks.  I do not believe this is due to browser or internet connection because I have tried it singling out every possible variable.  Jot form is the only common denomenator.  I would give a link but I had to change all of my forms to radio buttons as a temporary bandage but it is not functioning the way I need.  

    I have found that forms I created long ago have no problem.  It is only the forms I have created in the last couple months.  Has Jotform made any changes that could be causing this?  It started a bit of time after you guys had that "domain name fiasco".  Could this be related?

  • Profile Image
    jonathan
    Answered on September 24, 2012 at 05:54 PM

    @pandcproductions 

    Hi, can you please tell us which of your form is having this issue? We will check. 

    So far I have tested 2 of your forms that do have collapse fields (New Customer Content Form, New Featured Selling Ideas), but I could not reproduce yet the load display issue.

    Will be great also if you can create your own post for this so we can attend on your own concern personally. Please use this link to create your new post.

    Will await your response.

    Thanks.