What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Jotform.com Issues

    Asked by militaryspouse on February 06, 2014 at 10:04 AM

    Wanted to let you know that we have enjoyed your services for a few years now.

    However, the past few months jotform.com has become increasingly unstable. We will be working in a form, and the 'drag and drop' functionality will suddenly just stop working. It won't work again until we refresh the page. This will happen every few minutes in some instances. It is not a computer or network issue - as the site used to work fine for us. And we've tried on multiple co mputers on different internet connections. The issue is consistent. We're also contstantly getting 'server is down' type messages from jotform. Whatever changes were added to your site, it has become very shaky and a poor user experience.

     

    JotForm different site refresh
  • Profile Image
    JotForm Support

    Answered by KadeJM on February 06, 2014 at 11:18 AM

    Thank You kindly for your comments about our services. To my knowledge I know and can say that we've made some updates as we often do on a weekly basis along with routine maintenance and the implementation of new features and updates on occasion. For the most part as soon as we discover things that are wrong they are fixed almost immediately especially when it is something major. As far as I know our System has been fairly stable from our end lately.

    Involving the Drag'n'Drop I tested this with my Test Account including an investigation of this on your account but I am not currently seeing any issues.

    Additionally, The " Server is Offline " Message is usually rare and only temporary due to the sheer amount of server traffic we get which can happen during our peaktimes. I've had it happen on rare occasion myself and it will normally quickly refresh itself a few seconds later to clear it up. Your location and internet connection can also have a major effect on this. There is also the possibility of hardware and home network which can additionally hinder this more too.

    What Browser/Browser Version have you been using that this is happening in? Have you tried it in different browsers aside of your browser of choice to see if the same thing happens? I have also cleared your browser cache from our end to see if this helps. You can try this your own at any time if you ever need to as well.