What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Matrix tables do not allow to switch to another language, it always changes to English

    Asked by Jonas Bujok  on February 07, 2014 at 02:59 PM

    Hello dear JotForm,

    I have problem with language switch in my form. I filled in all translations for all languages and when I open the form it opens correctly translated into default language. But when i change the language it changes into no translation instead of selected language. Am I doing something wrong? Translation works fine because I tried to change the default language to all my languages. Just language change inside the form doesn't work properly.

    Pleas help.

    Thanks ahead.

    Sincerely

    Jonas Bujok

    Page URL:
    http://jotformeu.com/form/40375041724347

    doesn't work JotForm translation translations problem
  • Profile Image

    Answered by EliezerN on February 07, 2014 at 03:55 PM

    Hi,

    After checking your form I can understand what you are refering to, the form does not change to the selected language, but to English even if it is not selected from the languages option.

    I investigated a bit deeper and found that the cause of the issue is the Matrix tables of your form, after removing them, the languages of the form worked properly.

    Please test this cloned form without the matrix tables: http://form.jotform.co/form/40376430545856

    For some reason it is not allowing to switch the language correctly. So, I have forwarded a bug ticket to our next level support so that they can find a prompt solution to this issue. We will update this thread once the problem is resolved.

    Thanks for your understanding

  • Profile Image

    Answered by emrew86 on February 10, 2014 at 05:29 AM

    Hi Jonas Bujok, the bug has been fixed