What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    My conditions are not working, even when they are enabled

    Asked by ebartosh on February 11, 2014 at 12:33 PM

    Hello,

    When I accessed my form (http://jotformpro.com/form/40365443387963) today to do some final edits, I found that almost all of my conditions were gone. I tried using the new Revision History feature, and found that between the versions at 1:56 and 1:57 on February 6th the majority of my conditions were lost, though they were not listed in the list of changes (e.g. by answering "No" on the first page, it should jump to page 5, rather than proceeding to page 2). I've discovered that most all of the conditional edits and new conditions I made after that point are also now gone. I save frequently, and know that at the end of my session everything had been functioning perfectly.

    This would be an absolutely huge undertaking for me to go back and make all of these changes again, is there anything you guys are able to do to recover the work that has now vanished?

    I so hope you can help, thank you so much in advance!

    all session jump February hello
  • Profile Image

    Answered by ebartosh on February 11, 2014 at 12:46 PM

    Correction, I am seeing now that my conditions still exist, but none of them are actually being executed when I view the form!

  • Profile Image

    Answered by EliezerN on February 11, 2014 at 02:31 PM

    Hi, thanks for the update on this matter.

    I cloned your form to better test it from my end. So, I made some tests and I was able to reproduce the issue. 

    This is very weird as all the conditions are there, but they are not working even when they are enabled. It seems that something is blocking the conditions. Despite I dedicated some time applying some troubleshooting measures I was not able to find the cause of this issue. So, I have forwarded this bug to our next level support so that they can helps to find the cause and the solution of this bug.

    We will inform you via this thread if we receive any update from our dev team.

    Thanks for your understanding

  • Profile Image
    JotForm Support

    Answered by liyam on February 17, 2014 at 10:47 AM

    Hello ebartosh,

    Upon checking your form, there are some parts of your conditions that appear incomplete or may have had some cache problems.  I tried to edit the condition #60 (the one that makes the form go to page 5 after selecting No), and it appears to work after saving the condition and saving the form.

    Here is the clone of the form where I made the said change: http://form.jotformpro.com/form/40474271791962

    You can try cloning the form I shared if you wish or you can try editing again your form and try saving your conditions that have an issue again.

    Please do let us know if you need further questions.

  • Profile Image

    Answered by ebartosh on February 17, 2014 at 01:35 PM

    Hello,

    I appreciate your help, however, you only fixed the one condition.. Still, none of the other conditions are working..

    This form itself was one of many clones, none of which have had any problems with incomplete conditions.

    I would appreciate if you would keep working on this, as many hours have gone into this form.

    Thank you!

  • Profile Image
    JotForm Support

    Answered by Mike_T on February 17, 2014 at 03:36 PM

    I have cloned your form and re-saved conditions one by one. Please check it out from your side:

    http://form.jotformpro.com/form/40475527244960

    If some conditions do not work, please provide us with their numbers.

  • Profile Image

    Answered by ebartosh on February 18, 2014 at 09:37 AM

    I'm sorry, I do appreciate the help, but literally none of the conditions are working on the clone you sent me.. They are all still exactly as they should be on the Conditions page, but none of them are carrying over to the form, even on your most recent clone! 4, 5, 6, and 7 are just a few examples of ones that aren't working..

  • Profile Image
    JotForm Support

    Answered by Welvin on February 18, 2014 at 11:14 AM

    Here's a clone version of your form with a small modification to your conditional logic settings. There are hundreds, and I must admit, this will take time for me to sort out. I see most conditional logics are correct so this should work on the live form.

    Clone version of your form, kindly check: http://www.jotformpro.com/form/40483967777978

    Thanks

  • Profile Image

    Answered by ebartosh on February 18, 2014 at 11:37 AM

    AHH thank you SO much!! This is finally what I've wanted to see!! I know that it's a big form with a ton of conditions, so I really appreciate you taking the time to work through it! Is this an issue on my end that I can prevent from happening in the future, or was it just a weird bug?

    Now, how do I get access to this clone you've made?

  • Profile Image

    Answered by Carina on February 18, 2014 at 11:41 AM

    You can copy the form link and follow our guide on how to clone a form from an url.

    Kindly let us know if you need more assistance.