PayPal Defaults Broken?

  • Profile Image
    amya
    Asked on July 14, 2011 at 09:36 AM

    My form used to not redirect to PayPal when no products were selected. Now it always redirects, and uses a quantity of 1 for a product that is not selected on the form.

  • Profile Image
    allanftd
    Answered on July 14, 2011 at 11:19 AM

    Hi amya,

    I tested your form using the URL http://www.jotform.com/form/11860108768 and it led me to this website http://www.amya.spruz.com/ after I hit the Submit button. It did not redirect me to Paypal as you described. Kindly try that URL instead and let us know how it goes.

    Thank you for using JotForm!

    JOTFORM SUPPORT

  • Profile Image
    amya
    Answered on July 14, 2011 at 12:02 PM

    It seems inconsistent. Sometimes it works?

    any difference between www. and form. URLs? Is Mac/Safari a problem?

    Gerry

  • Profile Image
    allanftd
    Answered on July 14, 2011 at 12:18 PM

    Thanks for your quick feedback, Gerry. There should be no problem if the forms are accessed from a Safari on Mac browser. For now, please use www.jotform.com instead of form.jotform.com. We appreciate your patience on this matter.

    JOTFORM SUPPORT

  • Profile Image
    amya
    Answered on July 14, 2011 at 02:21 PM

    I have zeroed in on the problem. It is a bit more complex.

    I have a "secret code" to allow approved persons to submit entries without paying. There is a condition on the ZIP field which hides the PayPal field when you enter 99999

    Now, try looking at the Payment field, then enter 99999 in the zip - pmt field is hidden. Now change the zip and the PayPal field appears but with the two "Guest" product options selected. This makes it go to paypal when the 99999 zip is used and it tries to charge for the two guest options!

    Weird. - Any way to fix or work around?

    Gerry

  • Profile Image
    allanftd
    Answered on July 15, 2011 at 01:58 AM

    Hi Gerry,

    Thanks for sharing this development. I tried several ways to bypass this automatic product selection in the Payment field including:

    - duplicating the form (click here)
    - adding a zero quantity product
    - converting the checkboxes into radio buttons
    - not making the payment field required (though not a good workaround)

    but all of them failed to work.

    What I would suggest as a quick workaround is to create two forms:

    Form 1
    consists of all fields except the payment field. There is also a condition wherein if the user enters zip code not equal to 99999, it will redirect to the second form below after clicking the Submit button. 

    Form 2
    contains the payment field 

    I have created a working demo form, please click here to test drive it. Kindly confirm if this will work for you or not.

    Thank you for using JotForm!

    JOTFORM SUPPORT

  • Profile Image
    amya
    Answered on July 15, 2011 at 09:18 AM

    That will do as a workaround, but I create quite a few of these so it is a bit more work. I trust someone is looking at fixing the underlying bug?

    How do I have both forms submit to the same database?

    Gerry

  • Profile Image
    NeilVicente
    Answered on July 15, 2011 at 10:59 PM

    Hi Gerry,

    After doing a coupel of tests in your form, I can confirm the existence of this 'bug'. The products with quantity properties get selected automatically after the payment field is hidden that is why you get redirected to the paypal page. I am not sure if that is meant to work that way but I will submit a ticket to confirm with our developers if this is indeed a bug and have them fix it as soon as they can.

    While we cannot guarantee a specific time for this, you'd be pleased to know that bugs take a front seat in our developers' priority list. We will let you know once this gets taken care of.

    Thank you and have a great weekend!


    Neil

  • Profile Image
    amya
    Answered on July 19, 2011 at 06:30 PM

    Any news on a fix? 

    I can't make your workaround work. 2 forms = 2 databases?

     

    Gerry

  • Profile Image
    NeilVicente
    Answered on July 19, 2011 at 08:18 PM

    Hi Gerry,

    The support ticket submitted for this bug has been tagged as important. That means the priority was increased. Our devs will look into it as soon as they can. Thank you for your patience.


    Neil

  • Profile Image
    amya
    Answered on August 09, 2011 at 06:57 PM

    Still no fix?

    I need this to work - Please...

    Gerry

  • Profile Image
    NeilVicente
    Answered on August 09, 2011 at 07:04 PM

    Gerry,

    The report ticket I made for your issue was cancelled because our developers weren't able to see the bug in action since you have modified your form.

    I submitted a new ticket with this sample form as a demo. We'll let you know once it gets fixed by our devs. We are sincerely sorry for the inconvenience caused.


    Neil

  • Profile Image
    NeilVicente
    Answered on August 09, 2011 at 07:06 PM

    By the way, here is the thread for the new ticket for your issue. Please refer to that thread for updates. Thanks!