What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Problem with auto notification email and link

    Asked by WCSPC on March 05, 2014 at 02:44 AM

    Hi,

    I am creating a form that can save information. Last year we had two forms one for registration that provided a link via email to applicants - it worked ok. This year I notice that you have a save faciliity and I have added this to the new form but it has the draw back that only one person can apply from one computer (or IP address?)

    We have two problems:

    The registration form - auto responder is not working, it is not sending an email to the applicant with a link to the form. It is sending a notification to our account but when you test the link it says that the form is not available.

    The link on the Thank you page works and it is identical to the one on the email.

    I have obviously done something wrong but cannot discover what - can you help please.

     

    The application form http://form.jotformeu.com/form/40454871448359 seems to be working well on my computer but not when tested on a mac and ipad. Is there any reason why this would be a problem?

    This matter is now urgent as we need to advertise the posts - can you help please.

     

    Many thanks, Sue Clowes

    Page URL:
    http://form.jotformeu.com/form/40455372951355

    email problem and registration form new form application form
  • Profile Image
    JotForm Support

    Answered by EltonCris on March 05, 2014 at 04:23 AM

    Hi Sue,

    Yes that's right. The new browser autosave feature only performs on the same computer and browser from where the form has been previously filled. You have to use the same browser, otherwise the saved browser data can't be autofilled on the form. This is different from the first autosave feature where it requires 2 forms. Guide: https://www.jotform.com/help/227-How-to-Enable-Auto-Fill-Feature-Save-Form-Entries-to-Continue-Later

    1. The autoresponder is working when I test your form.

    2. The 2nd form is disabled when I checked it on your account. This is the reason it displays "form not currently available message". Enabling that form will resolved this. Here's how:

    3. This form works just fine: http://form.jotformeu.com/form/40454871448359. Please try to clear your browser's cache and recheck. If the issue persists, please open this question into a new thread and provide more details how to reproduce the problem so we can assist you further.

    Thanks and Regards!

  • Profile Image

    Answered by WCSPC on March 05, 2014 at 12:48 PM

    Hi,

    I thought that I had enabled this form earlier today. I have cloned last years form and named it 2014. Is it possible that the link is looking at the wrong form? We had no problem with this process last year & I need this in case I have two family members applying from the same computer.

    I have just tried it again now and it has not emailed me a link. Would you look at this again please.

    Many thanks, Sue

  • Profile Image

    Answered by Carina on March 05, 2014 at 01:42 PM

    Regarding your email it is not in our bounce list and we have an email log:

    Current Server: /var/log/jotform/amazonSES.log:[05/Mar/2014:12:40:22 -0500] 40455372951355 AmazonSES Sent email to w****pool@gmail.com - MessageID:000001449354f6bd-0bf917a2-38c3-43c0-93ad-6ef2eb0d02e0-000000 - RequestId:3a5faf7f-a48d-11e3-8803-0d22c2e4fd76
    I made test submissions on a clone and received the notifications and the auto-responders. Have you checked your spam folder? Also you can take a look at our guide on how to prevent email bouncing.
    Regarding the other question, as the edit link was manually inserted, when you cloned the form it mantained the original form's edit link:
    Also in the thank you page, the edit link is of the original form: After editing the links the situation should be solved. Kindly let us know if you need more assistance.
  • Profile Image

    Answered by WCSPC on March 13, 2014 at 02:39 AM

    Hi,

    Thank you for looking at this for me but we still have a problem.

    I had set the form to expire and when I cloned the form it copied this information across. I have now updated this and the form seems ok.

     

    The problem is the auto-notification. I cannot get it to send a recipient email. It sends a test email to the organisations email address when i click test. I do not understand what I have done.

    I have checked my spam but it is not there.

    Thanks, Sue

  • Profile Image
    JotForm Support

    Answered by NeilVicente on March 13, 2014 at 09:17 AM

    Sue,

    The "Test Email" function can only send to the email address associated with the account. We have implemented this restriction to prevent email abuse.

    If you'd like to test if the autoresponder is being sent to the recipient email specified on the form, try submitting your live form. If you want to do test submits too many times and you do not want to increment submission counts, let us know and we subtract the number of test submits from your monthly submission count.

    Please do notify us if you are still having issues.

    Cheres!