What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    How to insert form into Prestashop CMS?

    Asked by nicktechnology on March 11, 2014 at 05:09 AM

    Hello,
    How can I insert a page of the form CMS Prestashop? http://form.jotformeu.com/form/40523171788356
    Thanks

    Page URL:
    http://www.nicktechnology.com/it/content/category/6-richiesta-ricambi-<br/>auto-

    insert form jotformeu prestashop Prestashop CMS
  • Profile Image
    JotForm Support

    Answered by KadeJM on March 11, 2014 at 09:30 AM

    Yes, As far as I know that should be possibly by placing the form within an iframe on any of your store pages depending on where you want to put it. Additonally I would like to point out that you can try using this plugin here http://mypresta.eu/en/art/know-how/tinymce-editor-full-options-all-html-tags.html with a workaround referred to by a user in this thread in case the iframe isn't working the way you want it to.

  • Profile Image

    Answered by nicktechnology on March 11, 2014 at 10:36 AM

    Thanks for the reply,
    When I insert the code for the form in CMS page.
    I have this error.

    Property CMS->content is not valid
    at line 878 in file classes/ObjectModel.php

    872. 873. $message = $this->validateField($field, $value, $id_lang); 874. if ($message !== true) 875. { 876. if ($die) 877. throw new PrestaShopException($message); 878. return $error_return ? $message : false; 879. } 880. } 881. } 882.
  • Profile Image

    Answered by nicktechnology on March 11, 2014 at 10:39 AM

    I also reset the module Prestashop CMS, and always lying error.

  • Profile Image
    JotForm Support

    Answered by KadeJM on March 11, 2014 at 12:12 PM

    I do apologize about that and we appreciate you informing us about this. I've done some digging into your form and issue but I'm not exactly sure of the cause of the problem just yet because I am unable to replicate your Error that you mentioned right now but I will work on getting to the bottom of this for you. I would like to reassure you that this may take some time but I will be investigating this more to help figure out the cause of the problem and a feasible solution. At this point I feel very stongly that we will need to implement a guide on our platform so figuring this out more is necessary.

    What Host are you using your PrestaShop Software with? Or are you using your own Server for this? I looked in your source to see if I could figure that out but at the moment it appears that you are using the one included with PrestaShop aka " InMotion ". For testing purposes I may try that out and probably also test it on a standalone server. As soon as I can figure it out more I'll get back to you.

  • Profile Image

    Answered by nicktechnology on March 11, 2014 at 04:31 PM

    Ok Thanks
    the Host server and Shellrent: http://www.shellrent.com/web-hosting-azienda/


    PrestaShop™ 1.5.6.1

  • Profile Image
    JotForm Support

    Answered by TitusN on March 11, 2014 at 06:45 PM

    Thank you for the feedback.

    We are collaborating with Kade and running some tests to find the error.

    Thank you for your patience.

  • Profile Image

    Answered by nicktechnology on March 12, 2014 at 12:48 PM

    Ok Thanks

  • Profile Image
    JotForm Support

    Answered by KadeJM on March 13, 2014 at 10:12 AM

    Hey Nick, I appreciate the update about that. I just wanted to take a breif moment to give you an update on the status of whats going on with this and also I do apologize that I have not been able to get back to you about this just yet. It ended up taking me some time to work on this since I had to read into it all a lot more to better understand PrestaShop and using it along with setting it all up.

    I believe I've got everything set up and configured for the most part as of now. I tried it another way but realized that wasn't going to end up working using our server since I didn't have enough server privilidges on our end. I had also tried it via using my own computer as a test server but it was just taking way too long to try to set that all up though I may have to play around with that part more to check for third-party hosting errors being thrown just in case. To speed things up with finding a resolution I have also gone ahead and paid for a month of PrestaShop's Hosting in attempt to try to figure this out quicker for you.

    I've been playing around with it a little bit for awhile late last night and I've started on it some more as of early this morning as well to work on figuring this all out a lot more. So if you'll allow it and don't mind giving me a little bit more time on it that would be greatly appreciated. I will do everything I can to continue working on figuring this problem out to get to the bottom of the problem you mentioned asap. And I will try my hardest to get back to you by the end of today possibly a little longer then that at the most.

  • Profile Image

    Answered by nicktechnology on March 13, 2014 at 03:40 PM

    Hello, Thank you for help.
    If you want them I can create an account as a site administrator Nick Technology.
    Must do the recording on my website: http://www.nicktechnology.com/it/
    And active as an administrator.
    So we can take the test together.

    thanks again

  • Profile Image
    JotForm Support

    Answered by KadeJM on March 14, 2014 at 10:17 AM

    Good Morning from my side of the world and I just wanted to take a breif moment to thank you for the patience you've given with me with this as well as the offer for the account on your end. I have good news though as of mid yesterday which is that I believe I've figured out the cause of the problem so lets go ahead and try to get this resolved for you. 

     Below I've put together a quick guide but if you get confused or if a video would be easier let me know. I'm also going to turn this into a more detailed guide with a video for our Guide Section. Let me know how it goes or if you end up needing more help with it and we'll play around with it more to get you squared away if it comes down to it but I think this should work.

    Here's what I would suggest to try to fix this for you.

    (1) First " ENABLE " iFrames so that they are allowed on your forms. By default they are turned off so this causes unexpected problems and is the reason why an iframe for your form didn't work originally. To turn it on simple go back into your PrestaShop Administration Panel > Preferences > General and look for the 4th setting down the list labeled " Allow iFrames on Html Fields ". Change it to " YES " and save your setting for it.

    (2) Now, Grab the iFrame of your Form again but this time you're gonna need to modify it and just REMOVE ONLY THE SCRIPT PART and KEEP THE IFRAME. You're iframe code should now look something like this in example:

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="//form.jotform.us/form/40705110104131" frameborder="0" style="width:100%; height:633px; border:none;" scrolling="no"></iframe>

    (3) Next, Go back into your PrestaShop Admin Panel and this time " Create a New CMS Page " and put it into the Html Field of your Text Editor on the Page. Or if you want you can try placing it where you had it before if it was elsewhere but if not then it's gonna have to be there most likely to get it to work on your form then save it and preview the page and you're done!

    Final Result:

  • Profile Image

    Answered by Ed_03 on March 25, 2015 at 08:49 AM

    Hello, I have a form with some php functionality to capture form data and send it to email. When i embed it into a CMS page it doesnt not work. 

    Is there any way I can have a form on my CMS page (different from contact form), with the submitted form data going to my email? Please help!

  • Profile Image

    Answered by Ben on March 25, 2015 at 11:07 AM

    Since the issue is not the same I have moved your question to a new thread here: http://www.jotform.com/answers/540293 and we will be replying to it there shortly.