What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Embedding forms into Joomla 3.0 not working

    Asked by agabbydavis on March 16, 2014 at 01:45 AM

    Hello,

     

    I have read the couple of support you have for embedding forms into Joomla 3.0 - and nothing seems to work

    http://www.jotform.com/help/6-Adding-Form-to-Joomla and

    http://www.jotform.com/answers/86061-Can-you-insert-the-form-embed-code-into-a-Joomla-module

    Unfortunately, my Plug-In extension does not show all the details you provide..nor is there an option for HTML.. so I suppose you mean <> Source code.. 

    I do not see "Go to plugin parameters. Select "never" on "Code cleanup" on save option. Then save it.


    The attached image is what my module settings look like..



    Screenshot
    3 JotForm style size source
  • Profile Image
    JotForm Support

    Answered by NeilVicente on March 16, 2014 at 06:32 AM

    Hi,

    THe image you have attached is the screenshot of our instructions. 

    If you are using the latest JotForm version, or you can see the page under Basic Options (Plugin Manager: Editor-TinyMCE) such as in the screenshot below, simply remove script and iframe from the Prohibited Elements option, then hit Save.

     

    Afterwards, re-embed your form codes on your Joomla article or page.

    Let us know how it works for you.

  • Profile Image

    Answered by agabbydavis on March 16, 2014 at 05:40 PM
    OK, I will try this but unfortunately I was trying so many suggestion of Joomla users that I changed to Code Mirror.. it worked, but then I was not able to access Extended via TinyMCE.. so now I’m trying to get back to this. Right now, even after changing the info in TinyMCE, my articles and modules no longer appear with extended version.. maintaining the Code Mirror.. can’t get rid of it.. Thanks I will get back to you..

    ...
  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 16, 2014 at 11:18 PM

    Hello agabbydavis,

    Do try to implement my colleagues suggestion and that should solve your problem.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by agabbydavis on March 19, 2014 at 12:56 AM

    Hello,

    I used your suggestions and yes, it worked.  But, I can see that Joomla.org users had many issues with the TinyMCE.. thanks.. I have one more question though.

    Why do I see this "3% completed 1/26 fields populated." when I embed or preview.  THis didn't happen at first, although I made a few changes to the form.  Thanks again

    April

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 19, 2014 at 08:07 AM

    Hello agabbydavis,

    I did check your form and it seems that the issue is because of your form field "Date & Time of the event". In this date field your have set the "Default Time" as ON. That means when your form is loaded, it always has some value and that is the reason why it shows 1/26 fields populated. Please check the screenshot below:

    I would suggest you to remove the "Default Time" property and that should solve your problem.

    Hope this helps.

    Do get back to us if you have any questions.

    Thank you!

  • Profile Image

    Answered by agabbydavis on March 27, 2014 at 10:16 PM

    Hello,

    Thanks for your response, however I'm still receiving the load error.  I removed the Default Time.. which was not on when I looked at it.   This is the message I receive during preview and viewing source code before embedding and when I embed the form..btw, how do I upload an image from my computer..

    0% completed... 0/26 fields populated..

    Thanks for your continued help..

     

    April

  • Profile Image

    Answered by Cesar on March 27, 2014 at 11:38 PM

    I currently see the form load as 0% completed 0/26 fields populated. as opposed to 3% completed 1/26 fields populated:

    https://shots.jotform.com/cesar/screens/speakeriinquiryform.jpg

    Please provide the URL where the form is embedded, if the issue persists.

    So that we may assist you further. Thank you.

  • Profile Image

    Answered by agabbydavis on March 28, 2014 at 12:26 AM

    Hello,

    I see it when I put insert the source code onto my website.. My site is not yet up.. but it shows up in the preview.  It shows up in the preview from Jotform too.  It didn't do this before last week.  Please advise.. Thanks

     

  • Profile Image
    JotForm Support

    Answered by TitusN on March 28, 2014 at 04:16 AM

    That's Odd,

    We do not see what you see:

    Please do the following:

    1. Embed the form when you website goes live - or at least do a test page

    2. Share the URL with us so that we can take a look and advice.

    When you complete this, please open a new thread so that we can track the issue properly and offer qualitative support -

    Thank you for sticking through this.

  • Profile Image

    Answered by agabbydavis on March 28, 2014 at 02:15 PM

    Ok, I'm confused.. what do you mean you can't see what I see. The previous support person said he sees 3% complete.. I don't know I don't want this to be a problem when the site comes live.. just can't figure out what occured between the last two weeks.. and two years when it was all OK.. and only occurred while revising the form.   Thanks

     

  • Profile Image
    JotForm Support

    Answered by TitusN on March 28, 2014 at 02:27 PM

    My sincere apologies - I did not mean to confuse you.

    Kindly review the entire thread by clicking this link.

    The original issue has evoloved into a different support request (Embedding the form in Joomla)

    Please open a new suppor thread for the percentage indication issue during loading.

    Our support process works best when each issue has a separate thread for tracking and effective responses.

    Looking forward to your response.