What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    I cannot save my form

    Asked by tpf on March 20, 2014 at 12:39 PM

    When I try to save I get "There was an error on the page. Try reloading the page.

    When I click on the "source" button nothing happens.

    I'm also getting error messages re. the server.

    What's happening! Is the problem on my end or your end?

    Please help. I'm under a deadline!

     

    UPDATE: I cannot save ANY of my forms or get "source code" for ANY of them! Help!!!

    Page URL:
    http://www.jotform.com//?formID=40774241924152

    problem source deadline
  • Profile Image

    Answered by njrefine on March 20, 2014 at 02:18 PM

    Hello there!

    Are you still getting the same error messages? This happened to me once before. What I did was I cleared history (browser) and then restarted my computer, modem & router. Maybe that'll work for you, too. 

    I hope the error messages be gone after the powercycle.

    :)

  • Profile Image
    JotForm Support

    Answered by Welvin on March 20, 2014 at 04:07 PM

    Hi,

    Our apologies for the issue. We do have a problem to our servers and we don't receive similar report from the other users so most probably, that's just a temporary timeout and/or form caching issue. To fix that, please kindly logout from your account, clear your browsers cache and remove Jotform cookies from your browser the login again. That should do it. If now, please update us here so we can check further.

    Thanks

  • Profile Image

    Answered by tpf on March 20, 2014 at 04:36 PM

    Per an earlier suggestion (thank you!), I cleared my cache & browser history (including cookies). No change.

    I called our network service company about rebooting our server & modem. They said to call the ISP about rebooting the modem first.

    I have a service call in to my ISP about our network modem.

    I have rebooted my machine. I've tried usind other browsers.

    Sometimes I'm getting an error about Jotform servers being down. Sorry, I didn't copy the exact error screen.

    Here's a big troubleshooting clue: I just logged in to another jotform account I have for another organization, everything saved perfectly!!!

    The problem seems to be with THIS account, not just this form, but all the forms associated with this specific account!

  • Profile Image

    Answered by tpf on March 20, 2014 at 04:54 PM

    I think I just found the solution:

    I went in to my jotform account, selected "Settings", and under "Form Caches" clicked on the [Clear Cache] button.

    Everything's working. Let's see if it's permanent!