My survey respondents are reporting errors when submitting, how can we fix this?

  • Profile Image
    cdtcmpo
    Asked on November 17, 2021 at 01:35 PM

    We have had multiple survey respondents report errors when submitting their forms and send us the attached error message (they should be receiving the submission confirmation emails that we created). We have found that having the user clear the browser cache before beginning the survey helps this issue but we would like to know why this is happening and how we can be proactive about fixing it. If we cant resolve this we may not be able to continue to use jotform for this data collection effort.

    This may be an issue better discussed over the phone.

    Screenshot
  • Profile Image
    Amin_N
    Answered on November 17, 2021 at 05:52 PM

    Hi there,

    Thanks for reaching out to us!

    Which form you're referring to?

    Also, if the issue still exists, please use this domain for your form: https://cdn.jotfor.ms/ followed by the form ID, which should resolve the issue.

    Please give it a try and let us know how it goes.

  • Profile Image
    cdtcmpo
    Answered on November 18, 2021 at 11:42 AM

    Hi, thanks for your response!

    This has happened on the following forms.

    1. 2022 TIP Road Project Application
    2. 2022 TIP Bicycle Facilities Project Application
    3. 2022 TIP Pedestrian Facilities Project Application
    4. 2022 TIP Safety Project Application
    5. 2022 TIP Other Project Application
    6. 2022 TIP Bridge Project Application

    I will update the links to use the domain you noted above, however, how will I be sure that form is working effectively on the "front end"? Is there a way that I can be notified when a respondent receives an error and their submission does not go through?


  • Profile Image
    gerardw
    Answered on November 18, 2021 at 12:35 PM

    I have cleared the form cache on your account.

    Please test submit any one of the forms that you mentioned above from your end and check if you are getting the same error.

    Unfortunately, there is currently no option to notify you when your respondent receives an error.

    Additionally please let us know if you have embedded the forms on any website or are your respondents filling the direct form link?

  • Profile Image
    cdtcmpo
    Answered on November 19, 2021 at 02:49 PM

    I have tested from my computer with the new domain and was able to submit. The forms are not embedded. I am directing my respondents to the forms using the link.

    I had another respondent receive the error message today, but I think they may have started filling out the form prior to me changing the domain in the link.


  • Profile Image
    Sonnyfer
    Answered on November 19, 2021 at 04:58 PM

    Thanks for updating us. We're glad that the new link works for you.

    Please feel free to reach out again if you need help.