Can't integrate Stripe into payment field

  • Profile Image
    WhiskerBakes
    Asked on November 18, 2021 at 08:28 PM

    Hi,


    I have a Stripe account that I have been using prior to creating my JotForm. I tried integrating it into my form. I've attempted multiple times and each time I get redirected to Stripe and try, Stripe shows I've successfully connected. However when I'm redirected back to Jotform, it still tells me to connect to Stripe.


    This is like a never-ending cycle and I am unsure how else I can try to connect my Stripe account to the form. Can I get some assistance with this please?


    Thanks!


    Best regards,

    Azraini

    Screenshot
  • Profile Image
    Nina
    Answered on November 18, 2021 at 10:31 PM

    Hi there,

    Thank you for contacting Jotform Support and we apologize for the inconvenience.

    I cloned your form and checked your Stripe Integration. Upon checking, it shows that there is no stripe account connected yet.

    1637292554_61971a0a9378f_

    It should say "connected" when successful.

    Can you please try to remove the payment field, and add it back again? Then connect your Stripe account by following this guide- https://www.jotform.com/help/190-How-to-Integrate-Stripe-with-your-Form


    Hope this works out. Do let us know how it goes.

    Cheers,

    Nina

  • Profile Image
    WhiskerBakes
    Answered on November 19, 2021 at 11:31 AM

    Hi Nina,


    I have tried your suggestion before contacting yourself and have also attempted again. It still would not connect to Stripe on your form despite showing that I'm connected on Stripe. Is there any other way to fix this?


    Thanks!

  • Profile Image
    Gaetan
    Answered on November 19, 2021 at 11:49 AM

    Hello,

    Thank you for letting us know.


    I have cleared your form's cache, could you try to reconnect now? (maybe try with a different browser, we are never too sure).


    Best regards

  • Profile Image
    WhiskerBakes
    Answered on November 19, 2021 at 12:08 PM

    Hi,


    I tried a different browser and it's worked now, thanks! I have another issue though.

    For some of my products, there is a variety of options available, each with different pricing. I've set the product up with the special pricing and sub-products options on.

    However, when I preview the form, I can only select the quantity for sub-product options 3-6. Whenever I try to select the quantity for sub-products 1 and 2, the item section just collapses making it impossible to change the quantity for those options. Is there something I'm missing - like a limit for sub-products?


    Thanks!

  • Profile Image
    Michal
    Answered on November 19, 2021 at 01:14 PM

    Hello!

    As your new inquiry is unrelated to the original one, I will be splitting it into a separate thread and will answer it there:

    https://www.jotform.com/answers/3526036

    Thank you!