Problem with preselected field and conditions

  • Profile Image
    guelphlittletheatre
    Asked on July 23, 2011 at 09:11 AM

    I am developing a form with multiple pulldowns. One of the conditions is giving me a problem. If I select Dog in the 1st pulldown then in the 2nd the fabric for the blanket is shown with the first entry of the pulldown preselected (this is working). But I have two conditions (the last two of the form) that specify if the fabric is wool or denier then show a 3rd pulldown with options. If it is either of the two jersey selections then show a 4th pulldown with different options. These conditions all work as I choose different items in the pulldowns. However, the first time the 1st pulldown selects Dog then the 2nd pulldown is shown with the preselected item (wool) but the 3rd pulldown is not visible. It only becomes visible after I choose another fabric and then come back to the first item in the pulldown (i.e. the one that was preselected). Can you have a look please. Thanks

  • Profile Image
    NeilVicente
    Answered on July 23, 2011 at 12:46 PM

    Hi,

    Conditions only trigger on user-initiated action, that is why the 3rd field (Added Features) does not show up at first upon choosing "Dog" even if the default value for the 2nd drop down is "Dog Coat/Melton Wool".

    What you need to do is to re-work the rules in the condition that displays the "Added Feature" field to something like this:

     

    This way, the 3rd option field in your form will display upon choosing the option "Dog" in the "For which animal" drop down, since the default value for the 2nd drop down is "Dog/Melton Wool" and is not "Dress Fly - Heavy Jersey" or "Dress Fly-Lite Jersey".

    For your convenience, I went out of my way and applied the necessary changes to your form. Please check it out to see if the changes suit your needs.

    We look forward to your response. Thanks!


    Neil

  • Profile Image
    guelphlittletheatre
    Answered on July 23, 2011 at 02:28 PM

    Ok User-Initiated explains it all. Thanks for adding the fix and for the clarification.