UNDEFINED hint text appears on the fields

  • Profile Image
    newvmi
    Asked on April 09, 2014 at 02:55 PM

    When I test my form on my website, many of the boxes have "undefined" in them.  I CAN type over the "undefined", but when I try to go to the next section, I get a message "this field is required."

  • Profile Image
    EltonCris
    Answered on April 09, 2014 at 03:58 PM

    Hi,

    That's most probably due to script conflict. The form script might be conflicting the existing scripts on your page. If you're still experiencing this problem, please re-embed your form using iframe embed code. This should fixed the problem. Getting-the-Form-iFrame-Code

    Regards!

  • Profile Image
    newvmi
    Answered on April 10, 2014 at 09:30 AM
    Thank you. Well, it's definitely different. Now I get a blank box. I'll keep
    trying different codes.
    ...
  • Profile Image
    EliezerN
    Answered on April 10, 2014 at 11:17 AM

    @newvmi

    Could you please try using the iframe code again, but at this time remove the <script> part? So, the part you have to use now is this one:

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="//www.jotform.us/form/40964165743157" frameborder="0" style="width:100%; height:2532px; border:none;" scrolling="no"></iframe>

    Please let us know if the issue still persists.

    Thanks

  • Profile Image
    newvmi
    Answered on April 10, 2014 at 05:00 PM
    Nope, I have the original problem again. Could this be a result of some blocker
    ...
  • Profile Image
    jonathan
    Answered on April 10, 2014 at 08:11 PM

    Hi,

    I tested the form in your website 

    http://www.newvmi.org/our-ministries/the-back-yard-1/call-to-duty-registration/  but I was not able to reproduced and see this issue

     

    Can you please confirm if this issue is resolved already?  

    Or perhaps I am looking at a wrong page..  please correct if I did.

    Thanks.

  • Profile Image
    newvmi
    Answered on April 11, 2014 at 06:20 AM
    I had been using Internet Explorer. I tried it on Safari & voila! No problems!

    Now I just have to search your manual & find out how to make that pesky payment button show up.

    Thanks.

    ...
  • Profile Image
    jonathan
    Answered on April 11, 2014 at 08:12 AM

    Hi,

    I checked again on your website http://www.newvmi.org/our-ministries/the-back-yard-1/call-to-duty-registration/  BUT the registration form is no longer available. Perhpas you had it removed already?

     

    I also check the form in your account http://www.jotform.us/form/40964165743157 , but it really does not have a Submit button on it, so, there is no button available.

    You can just add a Submit button to it then.

     

    Please inform us if issue remains.

    Thanks!