Issue with prepopulating dropdown field that contains &

  • Profile Image
    jebdasteel
    Asked on January 04, 2022 at 11:19 AM

    Hi there. I have one field that I can seem to figure out why it won't prepopulate another survey properly. The field name is industry17 for both surveys. The redirect and prepopulate instructions are in the survey called CX Metrics Survey and it is set up to prepopolate the survey called CX Capabilities Survey.

    Can you take a look at this and tell me what I'm missing? All the other fields are working properly.

    Thank you!

  • Profile Image
    parker
    Answered on January 04, 2022 at 12:34 PM

    Hello,

    The problem is with the values that you've used including &, I would change these to the word and as that will work correctly. Since & is the same character for moving on to the next query parameter it's breaking it and moving on. If you try it with ones that don't include this it works fine as the first one I tried was with agriculture worked as intended.

    If you use the prefill app, you'll see for that it needs to look like this.

    ?industry17=Advertising%20%26%20Marketing

    for that section but since you're just pulling in the string value it will get the & as is.

  • Profile Image
    jebdasteel
    Answered on January 04, 2022 at 03:33 PM
    Parker, that worked perfectly. I just used ‘and’ instead of ‘&’. I should have thought of that, since I have had similar experiences with the & symbol in other apps.
    Thanks so much. You guys - and your product - are great!
    Jeb
    ...