the submit button does not seem to function on my website

  • Profile Image
    shoreline
    Asked on April 29, 2014 at 12:47 AM

    website cms: godaddy website builder

    website form url:  http://www.shorelinebaptist.org/registration-sports-vbs.html

    problem:

    After filling in all required fields I can push the submit button all day without moving from the page/getting a reply message/ or getting an error message.

     

    Notes:

    this page/form has been a functioning page until changes were made to the form tonight.

    The changes were to the introductory text, and two check box option were added to the top of the form.

     

    Following the changes the notification values were reviewed, and the autoresponder 1 values were reviewed.

    Following the review of those values the thankyou values were reviewed.

    Next I tried to embed code using the Embed Form option.  I copy/pasted the script into a new html field in the website builder cms (as is required).  No form fields showed up.

    With that failure, I tried copy/pasting source code script into a html field in the website builder cms.  Still no form fields.

    Next I tried copy/pasting Iframe code into a html field in the website builder cms.  Still no form fields.

    Last I again selected the source code option in jotform.  I previewed the page from there.  I then used a web tool to display the source code of the previewed page.  From that data I copied the relevant section of the previewed source code (you can look at the page and see the start and end lines of the copy).  I pasted that code into the cms and finally I could view and use the form.  Upon publishing I tried the submit button and it fails.

    Please help

     

  • Profile Image
    ashwin_d
    Answered on April 29, 2014 at 03:57 AM

    Hello shoreline,

    I'm sorry for the trouble caused to you.

    I am able to replicate the issue you are having. I did try to submit your form but clicking on "Submit" button does not do anything.

    To solve this problem, you need to embed your form using it iFrame embed code. The following guide should help you grab your form's iFrame embed code:  http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    Please be noted that godaddy website builder uses SSL and that could be the reason why your form is not displayed in the builder as you are using non secure embed code. I will suggest you to go ahead and embed your form with its iFrame embed code and check your live web page to see if the form is visible there or not.

    We will wait for your response.

    Thank you!