Merge tags showing in form submissions when using Jot2Tweet App

  • Profile Image
    CheapAlice
    Asked on May 01, 2014 at 05:04 PM

    Hello,

     

    I use jot2tweet app to upload to twitter and then is forwarded to FB. one recent upload showed mergetags?

    another just after showed up fine. I have uploaded a screen shot 

    andy ideas what happened or why?

    Thanks.

    Lance.

  • Profile Image
    jonathan
    Answered on May 01, 2014 at 06:31 PM

    Hi Lance,

    I am not sure yet what had happened for that to happen on your end. But I just tested the Jot2Tweet app again just now, and it does well.

    My test form http://form.jotform.me/form/41206534693454?

     

    integration screen

     

    Tweet result

     

     

    ---

    You may also want to redo the integration.

     Remove the current integration and just run again the configuration http://apps.jotform.com/app/jot2tweet  to reconnect your form to Twitter.

    Please inform us if it persist and happens already on more than one occassion so that we can investigate. We will alert the developer also so that it can fixed immediately if there is a problem.

    Thanks.

     

     

  • Profile Image
    CheapAlice
    Answered on May 06, 2014 at 03:25 PM

    Hello,

    I did not remove the integration as it was showing well for most and only happened the once. It has just happened again so I will attempt to redo the integration but wanted to advise that it still happens.

    Please advise if there is any fix I can do.

  • Profile Image
    Mike_T
    Answered on May 06, 2014 at 04:43 PM

    It is not likely that you can do anything other than re-integration to fix this.

    If re-integration does not help, please let us know. In such case we will be able to escalate the issue to the developer of that App.

    Thank you.

  • Profile Image
    CheapAlice
    Answered on May 07, 2014 at 04:46 PM

    Hello,

    Sorry but re-integration did not fix the issue and merge tags still show occasionally as shown in above photo. I may have some insight into the reason but just a guess.  It seems that this may happen when the Jot2Tweet is uploading a form that has an image attached to it that has special characters in the title. Although the image is not part of the information that i am including in my merge tags. Just the fact that it was included on the form. I also have submissions view app on form and photo does not upload when it has the special characters and it seems to be these same customers whos info shows up as merge tags on twitter. Hope this makes sense.

  • Profile Image
    EltonCris
    Answered on May 07, 2014 at 06:33 PM

    Hi,

    Thanks for providing more details. I was able to reproduce the problem, though mine is a little different. Every time a file is uploaded, the submission will not forward on Twitter. Let me submit this to our developers so they can go with the further investigation.

    Thanks and apologies for any inconveniences caused.

  • Profile Image
    NeilVicente
    Answered on May 08, 2014 at 07:19 PM

    Can you please show us screenshots of tweets where the issue have recurred (aside from the first photo)?

    Kindly include the tweets before and after so that we can identify with which submission the problem has occurred. Hopefully, we may be able to recreate the issue by resubmitting the form using the data from the identified submissions.

  • Profile Image
    CheapAlice
    Answered on May 08, 2014 at 07:55 PM

    I have deleted from my twitter but may be able to get from a follower. Not sure you will be able to recreate as I have also changed the data which i believe was the cause (badly named photos). As i mentioned I also use submission view app to upload to my site. So when customers upload an image with a bad file name it does not show up. I contact them to advise why so that they correct by uploading a proper image file. I will see about getting you screen shot.

    Thanks.

  • Profile Image
    CheapAlice
    Answered on May 13, 2014 at 12:23 PM

    hello. OK just happened again. here is the twitter page.

    https://twitter.com/CheapAlice

    I don't know how to upload a screenshot to this reply (there was a button when i started this post)

    Please help...my cusotmers need this feature.

    Thank You.

  • Profile Image
    TitusN
    Answered on May 13, 2014 at 03:04 PM

    Hello,

    I see what you mean:

    I have updated the ticket to our developers of this new development, and will advice.

    Thank you for your patience.

  • Profile Image
    CheapAlice
    Answered on May 13, 2014 at 05:10 PM

    For the record, the entry just above the one highleted in pink with the problem is what it was supposed to say. I just tweeted it form twitter. 

    After that there has been a few more entries and all have come out just fine.

    Just every once in a while one shows up showing merge tags. (not sure if it is an issue with bad images as thought before because the image was correct on this particular upload and showed up just fine)

    Thanks for any insight.

  • Profile Image
    EltonCris
    Answered on May 13, 2014 at 07:18 PM

    @CheapAlice

    Thanks for your cooperation and for adding more details. There is no update as of the moment but we will surely inform you here once this is fixed.

    Thanks!

  • Profile Image
    CheapAlice
    Answered on May 14, 2014 at 07:50 AM

    FYI first submission this morning is showing merge tags:

    https://twitter.com/CheapAlice

    Thanks

  • Profile Image
    jedcadorna
    Answered on May 14, 2014 at 10:22 AM

    @CheapAlice,

    Are you referring to this?

    You'll be informed via this thread if any update is available. 

  • Profile Image
    NeilVicente
    Answered on May 19, 2014 at 11:18 PM

    Hi,

    We were having a hard time trying to recreate the issue on our end, but I have made some changes to the code which I believe is causing the problem.

    Please do let us know if the problem occurs again.

    Thanks!

  • Profile Image
    CheapAlice
    Answered on May 20, 2014 at 12:00 AM

    Thank you for all of the support and hard work you and all at Jotform are doing. I will advise and update.

    Thanks again.

  • Profile Image
    CheapAlice
    Answered on June 02, 2014 at 12:51 PM

    Hi NeilVicente,

    Well it just happened again about 15 minutes ago. 

    Why it happens with some entries and not others of the same form is a mystery.

    Let me know what info I can get you to help.

    Thanks.

  • Profile Image
    Mike_T
    Answered on June 02, 2014 at 02:52 PM

    Thank you for update. We will let you know when we have any news on this issue.