What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Text link target reverts to "_blank"

    Asked by dentondesigns on May 06, 2014 at 10:21 AM

    When adding a link to Text, the link target defaults to "_blank" which makes it open in a new window. I can change the link target either through the Insert/edit link dialog or Edit HTML Source. After clicking Complete, the link target change works as expected in the Form Builder preview. But if I preview the live form or reload the Form Builder page, the link target always reverts to "_blank". This happens regardless of what I change the target value to (_self, _parent, etc or removing the target attribute completely) or the method I use to change the target (insert/edit link, edit html).

    Please fix.

    This problem is also mentioned here

    http://www.jotform.com/answers/329392-Target-_self-is-being-reverted-to-target-_blank-while-using-it-in-Text-tool

    and here

    http://www.jotform.com/answers/324931-Target-open-link-in-same-window?entrymessage=10732640770

    target Form Builder JotForm problem source
  • Profile Image

    Answered by Carina on May 06, 2014 at 12:25 PM

    I could reproduce the same behaviour. I forwarded this to our developers' team so they can look better into this. 

    They will contact you via this thread once they have an update.

    Let us know if further support is needed.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on June 07, 2014 at 06:05 AM

    @dentondesigns

    This problem has been fixed. Kindly edit the html links on your form to open in the same window, then re-save your form.

    Let us know if you run into any other problems.